cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Paul_31
Aspiring Expert
275 Views
Message 1 of 8

I cannot connect to one (and only one) website

Go to solution

I have one website that none of my devices (iPads, iPhones, Apple Macs) will connect to - although they have done in the past. I suspect it is a problem with my router (SmartHub 2) rather than the devices as I can connect to the site (www.waterlanelc.co.uk) from other networks or via cellular.

I've rebooted all my devices and the router (although I haven't done a factory reset, which I'm hoping to avoid). I've tried connecting using both Safari and Google Chrome and both fail to connect

Does anyone have any ideas on how to overcome the problem, without doing a factory reset?

In all other respects I have zero problems with my network, with about 20 devices connected and no other issues with web browsing.

I've done some general Googling about the problem and seen that it's not a common problem, but does seem to randomly happen for some people, but I couldn't find any definite solution. I've also read (and I confess to being out of my depth here) that ISPs cache connection details and that I might have to wait for BT to flush their DNS cache (I did say I was out of my depth Smiley Very Happy ) before I can successfully connect again.

Any tips or suggestions gratefully received.

0 Ratings
Reply
7 REPLIES 7
253 Views
Message 2 of 8

Re: I cannot connect to one (and only one) website

Go to solution

@Paul_31wrote:

I have one website that none of my devices (iPads, iPhones, Apple Macs) will connect to - although they have done in the past. I suspect it is a problem with my router (SmartHub 2) rather than the devices as I can connect to the site (www.waterlanelc.co.uk) from other networks or via cellular.

I've rebooted all my devices and the router (although I haven't done a factory reset, which I'm hoping to avoid). I've tried connecting using both Safari and Google Chrome and both fail to connect

Does anyone have any ideas on how to overcome the problem, without doing a factory reset?

In all other respects I have zero problems with my network, with about 20 devices connected and no other issues with web browsing.

I've done some general Googling about the problem and seen that it's not a common problem, but does seem to randomly happen for some people, but I couldn't find any definite solution. I've also read (and I confess to being out of my depth here) that ISPs cache connection details and that I might have to wait for BT to flush their DNS cache (I did say I was out of my depth Smiley Very Happy ) before I can successfully connect again.

Any tips or suggestions gratefully received.


Hi @Paul_31 

Sorry I know it doesn’t help you but using my iPad on a SH2 that website displays without any problems.

Have you tried clearing your website data on all browsers. For Safari Settings -> Safari -> Clear History and Website Data. 

0 Ratings
Reply
Paul_31
Aspiring Expert
243 Views
Message 3 of 8

Re: I cannot connect to one (and only one) website

Go to solution

@VeteranISPUser Yes, cleared all History and Website Data on all devices and flushed the DNS Cache on the Macs using Terminal and still no joy. I know that it works on other networks because I connected straightaway when using the WiFi in my local hostelry last night. Also no problem when using my Three data on my mobile. It’s just my home network where it won’t connect. Strange.

0 Ratings
Reply
Paul_31
Aspiring Expert
206 Views
Message 4 of 8

Re: I cannot connect to one (and only one) website

Go to solution

Problem Solved! (I thought I'd report back as it may be of help to someone else)

Although I had previously rebooted the router in the hope it would solve the problem, it didn't. However, today I had a new electricity/gas smart meter fitted and it required the engineer swiching off all electricity at the fuse box for about 40 minutes whilst he did his work. Once he'd finished and restored power and the router booted I was immediately able to get on to the site that I previously couldn't. All my devices now connect to it without any issue.

I can only assume the total power down does more than a straightforward restart. Must have cleared something as normal service has now been resumed Smiley Happy

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
198 Views
Message 5 of 8

Re: I cannot connect to one (and only one) website

Go to solution

It will have been a straight forward restart but what will have happened because of the time scale that the router was off is that you're probably being routed through a different server which is allowing the website through.

0 Ratings
Reply
Paul_31
Aspiring Expert
186 Views
Message 6 of 8

Re: I cannot connect to one (and only one) website

Go to solution

@gg30340 Thanks for the info.

0 Ratings
Reply
Distinguished Guru
179 Views
Message 7 of 8

Re: I cannot connect to one (and only one) website

Go to solution

@Paul_31wrote:

@gg30340 Thanks for the info.


This issue can still happen it seems. What appears to be the case is the user IP address going stale causing this fault. A power cycle of the router usually fixes it to get a new IP address.

The thing to do is check the current one by typing

whats my ip

into google. Then power cycle - turn power to the router off and wait 15 seconds or more and re-power, and after it's logged in check the IP address. It should be different and the issue should be sorted.

0 Ratings
Reply
Paul_31
Aspiring Expert
166 Views
Message 8 of 8

Re: I cannot connect to one (and only one) website

Go to solution

@Andy_N Thanks, I’ll bookmark this ready for the next time.

0 Ratings
Reply