cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
846 Views
Message 1 of 5

Incredibly Slow Upload Speeds on Windows OS with 3rd Party Router

Dear All, 

I am having a strange problem, I checked lots of messages and websites couldn't find the real reason behind this problem.

I am a BT Full Fibre 500 Halo 3 User. I was not happy with some lack of BT Home Hub 2, I decided to change it with Netgear Orbi RBK 752( This is a wifi mesh system and it has 2 units, one is rbr750 which is a router and the second one is rbs750 as satelate) I decided to use RBR750 as the main router to keep network management simple in the home and have some fewer layers.

The problem is, On windows computers, the upload speed is really bad in some scenarios. And because we are working from home generally, The Video conferences started to become a nightmare. Attendees can not see my video or very poor quality in teams.  On the other hand, there is no problem if I use my iPhone, Android phone, iPad or ubuntu laptop. It is just happening to windows. And the strange part is I virtualized the computer that I am having a problem and it works fine as a virtual computer with NAT Network adapter from the computer which has a problem.

 

You can see the screenshots down below. I don't know why but it is getting annoying I feel like I am missing something. May I kindly ask your opinions and experiences?

Those are the screenshot of tests and settings. 

As a user name and password I tried both and all of the gave me the same results.

Username: broadbanduser@btbroadband.com   

Password: bt

Username: broadbanduser@btbroadband.com   

Password: BT

Username: broadbanduser@btbroadband.com   

Password: 

Username: bthomehub@btbroadband.com   

Password: bt

Username: bthomehub@btbroadband.com   

Password: BT

Username: bthomehub@btbroadband.com   

Password: 

 

Fast.com test from the Windows device which has a problem

fast.jpg

 

Speedtest App test from Iphone

Iphone 13 pro max speed test.png

 

Speed test App from Windows Conputer

speedtet.jpg

 

Orbi Internet Settings

orbi internet.jpg

 

Orbi Wan Settings

orbi wan setup.jpg

Thanks in advence.

 

Best regards guys and have a lovely weekend.

Tags (4)
0 Ratings
Reply
4 REPLIES 4
831 Views
Message 2 of 5

Re: Incredibly Slow Upload Speeds on Windows OS with 3rd Party Router

As it's Netgear, have you checked the firmware on both devices is up to date? Netgear have a long history of checks from the devices not finding updates, so check on the product page of the Netgear site.

https://www.netgear.com/support/download/?model=RBR750

How are the Windows devices connected? If WiFi try ethernet & vice-versa.

 

0 Ratings
Reply
817 Views
Message 3 of 5

Re: Incredibly Slow Upload Speeds on Windows OS with 3rd Party Router

Hello @rbz5416 

Thanks for your reply. I did the firmware updates as a first job before installing and I checked again the link that you have provided (thanks to that) and it seems up to date as you can see.

orbi firmware.jpg

 

orbi router mode.jpg

On the other hand, I also tried to use TP link archer c3150 as the main router and the result is the same. Once I remove the home hub and plug the 3rd party as the main router, things get wrong.

 

0 Ratings
Reply
795 Views
Message 4 of 5

Re: Incredibly Slow Upload Speeds on Windows OS with 3rd Party Router

Are all Windows machine affected & are they all connected the same way?

Google suggests that Netgear & BT IPv6 don't get on, so may be worth disabling on a PC & maybe the router too, see if that helps.

This MS article gives some troubleshooting but I'm always sceptical of their generic "answers". In this case the OP seemed to solve their problem by disabling a service that wasn't even referenced by the MS guy!

https://answers.microsoft.com/en-us/windows/forum/all/very-slow-upload-speeds/248299c3-5eb5-47bb-935...

But starting with as clean a slate as possible is a sound first step. So doing away with anything that's starting automatically, etc.

0 Ratings
Reply
757 Views
Message 5 of 5

Re: Incredibly Slow Upload Speeds on Windows OS with 3rd Party Router

Thanks for the reply, 

IPv6 disabled by default in all of my devices including windows, linux devices and orbi router itself. The problem is exist only in internet access. Local file copying is pretty fast. I am sure if will put BT smart hub back in between ftt and orbi it will start working again as expected. 

thats the annoying part of the problem 😞

0 Ratings
Reply