cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Conorb564
Beginner
449 Views
Message 1 of 12

Issues connecting a Nintendo Switch

Hi All,

I am having problems connecting My partners Nintendo switch to our Wi-Fi, I'm quite frustrated with it actually. It was purchased during the week of black Friday as a Christmas present, but by the time she got round to setting it up it was more like the 28th December. It connected to our Wi-Fi the first day and then the problems began. I immediately thought the product was faulty, after doing the usual steps of turning off the Wi-Fi, powering down the console etc. I must of tried 10/20 troubleshooting steps to no avail.

Next I contacted Nintendo(bought from the Nintendo website) and despite the console being a day old out of the box it was out of the return period by a couple of days... anyway I went through there customer support and ended up shipping it off to be repaired(this consoles has been played for max 4 hours) I received it back yesterday and it connected again for the first day and today it seems to be having the same issue. I now believe this to actually be down to my Wi-Fi/router or something. Can anyone please help me with this issue?

0 Ratings
Reply
11 REPLIES 11
licquorice
Distinguished Sage
Distinguished Sage
437 Views
Message 2 of 12

Re: Issues connecting a Nintendo Switch

Conorb564
Beginner
427 Views
Message 3 of 12

Re: Issues connecting a Nintendo Switch

Hi @licquorice

Thank you for your help, however this hasn't fixed my solution. The error seems to be DNS related "could not perform a DNS name resolution" I've tried both cloudflare and google DNS. I think my network uses the cloudflare one, at least when I check on my PC it does. Apologies is this isn't making sense I know very little about networking.
0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
421 Views
Message 4 of 12

Re: Issues connecting a Nintendo Switch

0 Ratings
Reply
Conorb564
Beginner
408 Views
Message 5 of 12

Re: Issues connecting a Nintendo Switch

Yes I have that switched off too, to no avail 😔

0 Ratings
Reply
DavidM
Moderator
Moderator
376 Views
Message 6 of 12

Re: Issues connecting a Nintendo Switch

Hi @Conorb564 and welcome to our community.

I'm sorry you're having problems connecting your Nintendo Switch. I have one myself and haven't had the problems you're describing. I started off by doing the following - 

  1. Place your Nintendo Switch within 10 feet of your WiFi router to ensure a strong wireless signal.
  2. Turn your console on and open the HOME Menu.
  3. Select Internet, and then choose Internet Settings.
  4. Your Nintendo Switch will automatically search for nearby WiFi signals. Select your desired network name (SSID) from the list.
  5. If your WiFi network requires a password, an onscreen keyboard will appear. Use the keyboard to enter your network's password and then select OK.
  6. The Nintendo Switch will test the WiFi connection. Once the test is complete, select OK to finish the process.

Do all other devices connect to the wifi? Mobiles etc?

Cheers

David

0 Ratings
Reply
Conorb564
Beginner
361 Views
Message 7 of 12

Re: Issues connecting a Nintendo Switch

Hi David,

Thank you for your help, Yes it seems to be a problem unique to my WiFi. All other devices do connect.
0 Ratings
Reply
matekaneve
Aspiring Expert
335 Views
Message 8 of 12

Re: Issues connecting a Nintendo Switch

It might sound weird, but try to switch the network security in the Nintendo settings from wpa2-psk to wpa-psk!

0 Ratings
Reply
Conorb564
Beginner
333 Views
Message 9 of 12

Re: Issues connecting a Nintendo Switch

Hi @matekaneve 

I've also tried this several times. Honestly I've tried so much, Tonight I done a factory reset on the hub and it seems to work. However I'm usually able to connect for one day any time I hard reset the switch. so i'm hoping we are good now. But will update in a day or two.

0 Ratings
Reply
Conorb564
Beginner
278 Views
Message 10 of 12

Re: Issues connecting a Nintendo Switch

A Factory reset on my Hub has resulted in the Usual, the switch has disconnected after 1 day of use. I don't know what to do anymore.
0 Ratings
Reply