cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
josephd
Beginner
351 Views
Message 1 of 8

Issues with reliable port forwarding on Smart Hub 2 using FTTP

Go to solution

I have what I assume is called FTTP. There's a fibre line coming from the telegraph pole to my house and terminating in a box which then has an RJ45 connection going off to my BT Smart Hub 2. It's a home broadband account, not business.

On my SH, I have set up port forwarding to 3 individual machines on my network so that I can access them by SSH when I'm not at home. I have a script running every minute on one of those machines to notify an internet-connected server what my IP address is  just in case it changes.

Unfortunately the port forwarding has been very hit-or-miss. It will work great for huge stretches of a month or so and then just stop for no apparent reason. When it stops, it will either start working by itself a few days later or it will start working if I powercycle the hub.

It's difficult to know what to "fix" when a problem is as intermittent as this one. So I thought I'd post on here to ask for advice. I'm open to solving the problem in one of the following ways:

1) If anyone can offer any help to troubleshoot the issue with that Smart Hub and make port forwarding more reliable then I would definitely be open to trying out any ideas.

- or -

2) I would also be open to the idea of switching the Smart Hub either for another brand of hub or even potentially setting up my own using a Raspberry Pi, assuming this is a thing that can be done?

If I go for option 2, I'll also need some sort of WiFi support but I don't mind if it's a separate device plugged into my LAN. I don't care about the voip landline thing as it's never actually worked anyway.

0 Ratings
Reply
7 REPLIES 7
licquorice
Distinguished Sage
Distinguished Sage
348 Views
Message 2 of 8

Re: Issues with reliable port forwarding on Smart Hub 2 using FTTP

Go to solution

Try disabling UPnP if you are manually forwarding ports, there may be a conflict.

You can use any third party router with a WAN port with FTTP as long as you don't require the Digital Voice service which can only be supplied by a home hub.

 

0 Ratings
Reply
josephd
Beginner
344 Views
Message 3 of 8

Re: Issues with reliable port forwarding on Smart Hub 2 using FTTP

Go to solution

@licquorice Thanks for the quick reply. Yes, I should have mentioned that I disabled UPnP several months ago when I first started getting issues, so it's definitely not that. There must be something else causing a conflict.

Can you (or anyone) recommend a good 3rd party router that is known for stability and a decent configuration interface, especially for port forwarding?

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
336 Views
Message 4 of 8

Re: Issues with reliable port forwarding on Smart Hub 2 using FTTP

Go to solution

Pretty much any third party router will fit the bill, depends on your budget really. Possibly avoid Netgear as, unless they have changed their stance, they don't support BT's implementation of IPv6. TP-Link or Asus models are popular.

206 Views
Message 5 of 8

Re: Issues with reliable port forwarding on Smart Hub 2 using FTTP

Go to solution

@josephd  did you manage to resolve this? I can't get port forwarding to work at all.

Is the solution really to buy another router? Did buying a new router improve the reliability?

This should work with the provided router! 😡

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
196 Views
Message 6 of 8

Re: Issues with reliable port forwarding on Smart Hub 2 using FTTP

Go to solution

It does. Port forwarding works fine for me.

0 Ratings
Reply
169 Views
Message 7 of 8

Re: Issues with reliable port forwarding on Smart Hub 2 using FTTP

Go to solution

I finally got port forwarding working. In case it is useful for anyone that stumbles upon this in the future:

For me, power cycling the router was not sufficient.
I needed to factory reset the Smart Hub 2 router

(1) Go to http://192.168.1.254/
(2) Click "Advanced Settings"
(3) Click "System"

(4) Click "Reset"
(5) Click "Factory Reset My Hub"

Re-setup your network from scratch. Now set up port forwarding following the usual instructions and it worked for me.

Factory reset working may be evidence that I had misconfigured my router somehow. But flaky port forwarding does seem to be a problem with the Smart Hub 2 according to the many posts on this forum. Perhaps the recommendation to purchase a better alternative really is necessary.

Some other things to note:

(1) Port 22 works as expected for ssh. I initially tried switching to alternative ports thinking maybe somehow port 22 was being treated specially. But after a factory reset port forwarding works with no problems with port 22.
(2) I can ssh from outside my home without problems.
(3) I found that connecting internally to the router i.e. ssh 192.168.1.254 does not get forwarded to my server. It just hangs and times out. It seems that you must connect from outside your home network via your public IP address

I hope that this is helpful to someone (possibly future me).

0 Ratings
Reply
josephd
Beginner
130 Views
Message 8 of 8

Re: Issues with reliable port forwarding on Smart Hub 2 using FTTP

Go to solution

@davebeeteecommunity Sorry for the delay in my reply. Your post is useful and actually the same thing I ended up doing a few weeks ago when the usual powercycle trick didn't work.

I don't personally think that you misconfigured anything any more than I did. I think that the router just gets confused when you create and delete a lot of port forwarding rules and that such confusion can be cleared up with a power cycle in some cases and a factory reset in others.

I realise that the word "confused" isn't really an accurate way to describe a problem with a router. But in my experience the Smart Hub 2 just isn't reliable. In my experience, port forwarding can work for days, weeks and months and then just stop even though I haven't touched the admin interface. If it was something I'd configured incorrectly then you'd think it just wouldn't work to begin with.

0 Ratings
Reply