cancel
Showing results for 
Search instead for 
Did you mean: 
Reaps
Contributor
1,018 Views
Message 1 of 10

Latency issue

Hi there,

 

I'm on 80/20 fibre and have been for a few years now.

In the last week, i've started receiving a lot of latency.

Investigations have been undertaken and I've managed to repeat the issue over and over.

When downloading anything at all, at a speed of 2-3MB/s (which should leave approximately 4-5MB/s free), my latency starts to spike. This means that watching something as little as Netflix (not in 4k), or watching youtube, causes my gaming pings to spike and make the game unplayable.

 

I can repeat this test over and over. 

When there is nothing occuring on the network, I get a great ping.

As soon as streaming occurs, I can no longer play games due to the increased/spikey ping.

This didn't occur until last week.

I called BT and they have said that my line is getting roughly the correct throughput, so can't do anything.

 

Here are my stats:

Stats recorded 10 Feb 2019 20:58:27

DSLAM type / SW version:   BDCM:0xb12d (177.45) / v0xb12d
Modem/router firmware:     AnnexA version - A2pv6C038m.d24j
DSL mode:                  VDSL2 Profile 17a
Status:                    Showtime
Uptime:                    2 days 4 hours 17 min 31 sec
Resyncs:                   0 (since 10 Feb 2019 20:58:24)
         
            Downstream   Upstream
Line attenuation (dB):     14.7      0.0
Signal attenuation (dB):   Not monitored      
Connection speed (kbps):   73406      20000
SNR margin (dB):           3.2      9.4
Power (dBm):               13.3      6.5
Interleave depth:          8      1
INP:                       53.00      0
G.INP:                     Enabled      Not enabled
Vectoring status:          5 (VECT_UNCONFIGURED)      

RSCorr/RS (%):             0.0067      0.0000
RSUnCorr/RS (%):           0.0000      0.0000
ES/hour:                   0      0

This is my TBB ping graph:

https://www.thinkbroadband.com/broadband/monitoring/quality/share/3231b72aaeddbe9affa9fa90faf557992b...

 

0 Ratings
Reply
9 REPLIES 9
Reaps
Contributor
1,017 Views
Message 2 of 10

Re: Latency issue

Just to stress, I normally stream to Twitch.tv, all my gameplay, while I played, while the wife was watching Netflix and I've never had any worries about my fibre or my pings, until now.

In essense, the line seems like it's no longer fit for purpose, as I can't do more than 1 thing at a time. Even though throughput isn't the issue for me, it seems like there's a fault on my line.

 

This is tested with both the HomeHub 5 and an HG612 with Ubiquiti Edgemax router, both have the same issue.

Any assistance would be greatly appreciated, before I call Tech Support once again. Thank you!

 

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
977 Views
Message 3 of 10

Re: Latency issue

have you been having problems with internet connection dropping or a few manual resets as you are showing interleaved depth 8 whereas possibly you were on Fast



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
Distinguished Sage
Distinguished Sage
966 Views
Message 4 of 10

Re: Latency issue

@Reaps

Possibly a lot of buffering occurring on the upstream path somewhere, which means that the acknowledgement and performance packets which are being uploaded when you are streaming video, are causing a delay on the upstream path.

Its difficult to say where this buffering could be taking place, but if you have the option on your own router, to lower the upload priority of the device which is streaming Netflix or YouTube, it may help.

If buffering is occuring on the BT network, like in the fibre cabinet DSLAM, there is not a lot you can do about it.

0 Ratings
Reply
Reaps
Contributor
965 Views
Message 5 of 10

Re: Latency issue

Thanks for the reply!

It's not been dropping connectivity as far as I'm aware.

I have switched over from HomeHub to my own equipment, to confirm it's not been my hardware at fault, perhaps that has caused a change in interleave depth?

Other than that, it seems to have been fine , bar some packet loss I experienced last week. More than happy to provide any details you need to help troubleshoot this.

0 Ratings
Reply
Reaps
Contributor
958 Views
Message 6 of 10

Re: Latency issue

I can apply and test QoS to lower the upstream bandwidth to half of my upstream, for everyone for the time being, to see if that helps.

My main priority here, is to allow me to enjoy my gaming again, sadly 🙂

If I can get my lower 20ms pings, while the wife is watching Netflix, we'll both be happy.

If there's something I can do to help, great.

If there's something BT can do to help, even better. I don't know enough about how their fibre network works, to try and convinence them to change something, although if like you that theres buffering occurring, perhaps no one can do much about it?

Would switching provider help in this kinda situation? Even though I'm 14 months away from contract end, I may consider buying out of the contract to get back to low latency.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
950 Views
Message 7 of 10

Re: Latency issue

The first thing would be to lower the upload priority on other devices, and give your PC/games console the highest priority. That should be quite effective, as the upstream path on streaming content, is not that critical, and can even be throttled back quite a bit, before the streaming rate would be affected.

I am on ADSL with a 10Mbs download and 800Kbs upload, and ran a test a few weeks back, and there was no effect on the ping reply to the BBC website, while streaming Netflix or YouTube.

This may be due of course, to the better network connectivity that ADSL enjoys, owing to its direct connection in the exchange, to the 21cn MSAN.  All users on a FTTC cabinet, have to share the same optical fibre back to the exchange, so some performance loss is to be expected, especially as more users are connected to the cabinet.

There have been a number of other reports on this forum of poor latency over the last few months, so it possible that over the holiday period, there was a large increase in new customers connected to the cabinet.

ISPs are concentrating on delivering Value Added Services, like YouView, as that is where the money is made, so I doubt very much that latency is even considered, as its not part of any SLA.

As all the providers apart from Virgin Media, use the  same Openreach cabinets, then changing provider may not help, and you may lose your fibre connection if the cabinet is full.

0 Ratings
Reply
Reaps
Contributor
945 Views
Message 8 of 10

Re: Latency issue

Very makes for a very interesting read, although it could be unforutnate for me.

I've always had no issues with streaming, while gaming - pings have never been effected for me either. I think I need to figure out how to properly use QoS on my Edgemax, to limit everyones throughput but my gaming rig.

I guess the test would be to run the same tests in the evening, as I am during the day - to review the results and compare. I guess that would cater for graphing the contention on the fibre.

I'm skeptical of others in my area all jumping on the BT TV all of a sudden, since where i live, is a fairly small area in Caerphilly, with not a huge alot of happening, especially no recent developments built around the area.

Re: losing my fibre - I guess I could query that with a call to BT anyway? I'm not an angry customer, just a determined one. 🙂

0 Ratings
Reply
Highlighted
Reaps
Contributor
899 Views
Message 9 of 10

Re: Latency issue

While looking into this - one of my colleague pointed me out to this: 
https://www.thinkbroadband.com/news/8274-caerphilly-added-to-list-of-fast-exchanges

Checked with bt.com - no gfast available on my account.
Checked with openreach - they say its ready.
Checked with another provider (zen) - they say they can provide me up to 130~Mbps

Called up BT, they said they can't provide it - as their systems have not yet updated and they basically see what I see on my account in bt.com
They say to wait a few weeks and keep checking the website, once its available there - it will be available to me.

Hopefully, this will mean they will have to move me on the infrastructure to somewhere new, especially as they will need an engineer visit to do it - which should mean they can physically test my line while they are there, to get max speed, low latency.

Is anyone on this forum able to help get this updated quicker? (if only)

0 Ratings
Reply
Reaps
Contributor
680 Views
Message 10 of 10

Re: Latency issue

Just to update my own thread.

Moved internet today.

Finally moved to Zen

All latency issues have been resolved.

https://www.thinkbroadband.com/broadband/monitoring/quality/share/3231b72aaeddbe9affa9fa90faf557992b...

0 Ratings
Reply