cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
gwelmarten
Newbie
2,656 Views
Message 1 of 3

Mac File Sharing - Stuck on Connecting - BT Home Hub

Hi

I'm having a bit of trouble with my home network. Before, I used to use a net gear router to connect both my iMac and my MacBook Air. Both had file sharing enabled, and I could easily connect to one from another and share files / share screen.

I upgraded to a BT Home Hub router. 

Now, everything still has file sharing enabled, but when I look at networked devices in Finder (including my NAS) and try and connect, it just gets stuck on Connecting - I can't even do "Connect As". See the attached screenshot.

I also tried connecting via afp to the NAS (a Synology box), and that just showed the bar with the diagonal lines that keep moving across it - meaning no progress!

Other people with Mac's and BT Home Hubs - how have you got file sharing to work?  I've seen a few articles with references to the Apple TV, but the steps don't seem transferable.  Or could it be something else? Any thoughts appreciated.

Thanks for your help in advanced.

Sam

Screen Shot 2012-07-10 at 10.24.15.pngScreen Shot 2012-07-10 at 10.30.53.png

0 Ratings
Reply
2 REPLIES 2
ptan
Aspiring Expert
2,649 Views
Message 2 of 3

Re: Mac File Sharing - Stuck on Connecting - BT Home Hub

Hi

 

I have had the BT HH3 for a year now. I have two iMacs, mac mini, AppleTV and also a PC. File sharing has been fine. One thing could be that not all the devices on your network have refreshed their DNS settings?

 

The HH3 doesn't block any network traffic on your local network.

 

What does the HH3 show when you go to Advanced Settings - "Home Network - Devices"  ... it should show all connected hosts?

 

ptan

0 Ratings
Reply
gwelmarten
Newbie
2,619 Views
Message 3 of 3

Re: Mac File Sharing - Stuck on Connecting - BT Home Hub - SOLVED

Hi

Everything was showing up, and I had requested new IP's on all devices.

The problem was the default firewall settings blocked everything.

I disabled the HH3 firewall (since I have a seperate one anyway) and all works now.

Sam

0 Ratings
Reply