cancel
Showing results for 
Search instead for 
Did you mean: 
bitsostring
Beginner
594 Views
Message 1 of 7

Microsoft Edge won't display BT Hub Manager

Go to solution

Following a Cumulative upgrade to W10 1803 (KB4480966, now at 17134.523) Microsoft Edge will not display homehub.home or 192.168.1.254. I can still see the page on IE11 and Chrome.

No problems with any other site I have visited today.

 

0 Ratings
Reply
6 REPLIES 6
584 Views
Message 2 of 7

Re: Microsoft Edge won't display BT Hub Manager

Go to solution

@bitsostringwrote:

Following a Cumulative upgrade to W10 1803 (KB4480966, now at 17134.523) Microsoft Edge will not display homehub.home or 192.168.1.254. I can still see the page on IE11 and Chrome.

No problems with any other site I have visited today.

 


Hi @bitsostring

No problem using Edge W10 1809 17763.195. I would try clearing your temporary files etc. or upgrading to the latest version.

0 Ratings
Reply
bitsostring
Beginner
572 Views
Message 3 of 7

Re: Microsoft Edge won't display BT Hub Manager

Go to solution

Thanks.

 

0 Ratings
Reply
bitsostring
Beginner
558 Views
Message 4 of 7

Re: Microsoft Edge won't display BT Hub Manager

Go to solution

I didn't say it had been solved!

 

0 Ratings
Reply
Moderator
Moderator
553 Views
Message 5 of 7

Re: Microsoft Edge won't display BT Hub Manager

Go to solution

@bitsostring ooops, sorry that was me. I've changed it back. Smiley Embarassed

0 Ratings
Reply
516 Views
Message 6 of 7

Re: Microsoft Edge won't display BT Hub Manager

Go to solution

Hi @bitsostring

Very strange, I have just switched on my Desktop PC (I use the laptop 99% of the time) and I find that all local addresses are ignored by Edge such as the BT Hub and the Printer web interface.

The solution for me was to specifically allow the local addresses in Windows 10.

1. Click on Windows (bottom left) or press the Windows key.
2. Type in Internet Options and run Internet Options (Control Panel)
3. Click on Security tab
4. Click on Local Intranet
5. Click on Sites
6. Click on Advanced
7. Add all the local websites like http://192.168.1.254/ to the Zone
8. Make sure it is all saved by clicking OK etc.

I can now open Edge and type in http://192.168.1.254/ and the Hub Manager opens.

For me it is/was clearly a Windows 10 problem and nothing to do with the Hub Manager. Works by default on my laptop but not by default on my Desktop PC. Both on on the same W10 release and version!

bitsostring
Beginner
502 Views
Message 7 of 7

Re: Microsoft Edge won't display BT Hub Manager

Go to solution

Thanks, VeteranISPUser, that seems to work here too!

I knew it was a Win10 problem as it only started after the latest update, and I suspected it was local IP addresses because every other site comes up, but didn't know how to get past it.

Now to tell the self-styled expert on the Microsoft forum what I think of his advice, which included (as a last resort) uninstall and reinstall Edge!