cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
923 Views
Message 1 of 4

No IPv6 (Stateless) Autoconfiguration over WiFi

I have a BT Fibre VDSL package with a Smart Hub 2

When I connect my Windows 10 Surface Book 3 to the LAN (wired ethernet to the router) the computer gets assigned (or assigns itself) an IPv6 address and public IPv6 testers (like ipv6-test.com)  recognise my IPv6 address, and I can use "ping -6 www.google.com" to check the IPv6 connectivity from inside my network.

But, when I connect via WiFi the IPv4 setup via DHCP works, but there is only "Link Local" IPv6 setup. Is this normal? I get the same behaviour (using a USB ethernet adapter) on an Android device.

In the Smart Hub 2 Advanced > IPv6 > Configuration page there is an option for IPv6 allocation mode (Stateless, Stateful, Both, Off). If I chose "Both" then my WiFi connected Windows machine gets an IPv6 address. Are there risks to this setup? 

Examples of the different configurations, running ipconfig on Windows...

ipconfig output for wired connection:

C:\Users\sjmac>ipconfig

Windows IP Configuration


Ethernet adapter Ethernet 2:

Connection-specific DNS Suffix . : home
IPv6 Address. . . . . . . . . . . : 2a00:2...4e3:bf9a
Temporary IPv6 Address. . . . . . : 2a00:2...e68:5e2a
Link-local IPv6 Address . . . . . : fe80::7...f9a%16
Default Gateway . . . . . . . . . : fe80::3...c46%16

Wireless LAN adapter Local Area Connection* 1:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Wireless LAN adapter Local Area Connection* 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Wireless LAN adapter WiFi:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::a...304%20
IPv4 Address. . . . . . . . . . . : 192.168.0.93
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

 

If I connect the same computer to the Smart Hub (or another access point on the same network) using WiFi then I can see there is no gateway for IPv6 traffic, and public IPv6 tests show that I do not have an IPv6 link (ipv6-test.com)

ipconfig output for WiFi only:

C:\Users\sjmac>ipconfig

Windows IP Configuration


Wireless LAN adapter Local Area Connection* 1:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Wireless LAN adapter Local Area Connection* 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Wireless LAN adapter WiFi:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::a...304%20
IPv4 Address. . . . . . . . . . . : 192.168.0.93
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tags (1)
0 Ratings
Reply
3 REPLIES 3
909 Views
Message 2 of 4

Re: No IPv6 (Stateless) Autoconfiguration over WiFi

Works fine for me via WiFi with IPv6 configuration set to Stateless.

905 Views
Message 3 of 4

Re: No IPv6 (Stateless) Autoconfiguration over WiFi

Don't know what's happened there. I have an SH2 which I've left set to Stateless and I get a v6 address OK when connected by Wi-Fi


A thank you is nice, it makes the effort worthwhile, but a kudo is better, by a country mile. (I'm no poet & boy don't I know it)
892 Views
Message 4 of 4

Re: No IPv6 (Stateless) Autoconfiguration over WiFi

Thanks @Les-Gibson , @licquorice - that's at least helpful to know. 

I have a slightly odd config with the Smart Hub IPv4 DHCP server turned off, and I have another ISP connection available via the same LAN. 

At the moment traffic is split (by accident) to send all IPv4 traffic via VirginMedia, and any IPv6 traffic goes through BT. (VirginMedia don't currently route IPv6 on their residential connections.)