cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Aspiring Contributor
458 Views
Message 1 of 11

Panasonic smart tv won't connect to internet with ethernet and smart hub.

Hi, completely new to this so please forgive obvious errors on my part. 

I have a Panasonic smart tv that I want to connect to smart hub via ethernet cable (trying to connect as much as possible in the house via wire not wifi to ease the burden). However the tv simply wont connect, although it does fine over wifi. 

The tv shows that there is a connection to the router and the network but it doesnt have connection to the internet. 

All cables have been checked and tested, numerous ports have been tried, tv has been reset and router has been switched off and on again many times. I have sworn lots and seen off a number of bottles of wine over the past few days trying to sort this out. 

Having searched high and low the current wired settings on the tv are:

IP 192.168.1.49 (static)

Subnet 255.255.255.0

Gateway 192.168.1.254

DNS 192.168.1.254 (have tried 8.8.8.8 & 8.8.4.4)

So, any help (in very simple terms please) would be greatly appreciated. 

Cheers Ben

0 Ratings
Reply
10 REPLIES 10
Highlighted
Distinguished Sage
Distinguished Sage
456 Views
Message 2 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

Highlighted
Aspiring Contributor
443 Views
Message 3 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

Thanks for quick reply. I'll give that a go, fingers crossed.
0 Ratings
Reply
Highlighted
Aspiring Contributor
417 Views
Message 4 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

Quick update, smart setup is now off but still no joy sadly! 

Any other suggestions or more info I can give?

0 Ratings
Reply
Highlighted
Recognised Expert
401 Views
Message 5 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

@Donfiben 

Are you manually entering the IP address etc into the TV or letting it get the details automatically from the router?

If you've entered it manually into the TV have you fixed it within the HomeHub as well?

Highlighted
Aspiring Contributor
385 Views
Message 6 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

@TimCurtis 

Thanks for reply. Yes, I'm manually entering IP into tv and the smart hub shows the same IP and that it is static. Not sure that is what you meant as I haven't directly entered it into the hub as well as the tv. 

I keep getting "gateway not responding". But the tv connects fine on wifi. It's all very strange!

0 Ratings
Reply
Highlighted
Distinguished Sage
Distinguished Sage
376 Views
Message 7 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

You could try setting the TV to get a DHCP address from the hub rather than using a static address. It shouldn't make any difference but the problem is totally weird anyway.

Sure you haven't made a typo with the gateway address?

Highlighted
369 Views
Message 8 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

The problem with static IP addresses is that they need to be managed to ensure that you don't have an IP clash, i.e. two devices vying for the same address. I would try changing that to DHCP (or Automatic) as advised by @licquorice 

Highlighted
Aspiring Contributor
333 Views
Message 9 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

@V_Meldrew @licquorice 

Thanks for the continued tips, I'll try returning to DHCP and automatic settings on the tv. I'm guessing  that I may need to consider resetting the router and tv again so it all starts from a clean slate (remembering to check that smart setup is off). 

I'll let you know how I get on.

0 Ratings
Reply
Highlighted
323 Views
Message 10 of 11

Re: Panasonic smart tv won't connect to internet with ethernet and smart hub.

No, if the problem is a clash of IP addresses then you shouldn't need to reset the router but yes, you should turn off Smart Setup.