cancel
Showing results for 
Search instead for 
Did you mean: 
thestalosj
Aspiring Contributor
337 Views
Message 1 of 2

Poor Wifi Speeds + no 5ghz tempted to leave bt

My BTHH6 (Smart hub) has poor signal, I live in a 2 bed house and I don't get any signal downstairs.

When I do finally connect with my phone it's on the 2.4ghz band and the speed is terrible 6-7mbps.

The Smart Hub has been the worst money I have ever spent on a router, even when I try to split the wifi bands using the Routers config page it does not actually split. It says it has but none of my devices detect the 5ghz band (Samsung S7 Edge, Ipad Pro, Wii U, Nvidia Shield).

So If someone could Actually help me before I just leave BT and go to Sky For everything instead 

0 Ratings
Reply
1 REPLY 1
Ian7777
Aspiring Contributor
303 Views
Message 2 of 2

Re: Poor Wifi Speeds + no 5ghz tempted to leave bt

Try a factory reset by sticking a paperclip in the hole in the back, then try splitting the frequencies again.(and turnoff Smartsetup).  Then check the maximum data rate in the advanced settings technical log, this should be faster or equal to your promised infinity speeds.  (If its not there may be a line/hardware problem call BT, it will be the same line as SKY uses).

 

When I first had the HH6 I had a few problems - but after a factory reset, splitting the Wifi signal and turning off Smartsetup its become a very stable router much better than my HH4 it replaces. No crashes and solid wifi, mine has been up for weeks. Note you may need to change the wireless mode setting, as some older devices do not like Mode 1.

 

My HH6 may still have a few odd issues with Chromecast devices in group play (which I am still investigating and blame may lay elsewhere).  However I have pretty solid 2.4ghz coverage across a 4 bedroom house giving nearly my max infinity 1 speed to 10 devices (50mbps).  5GHZ is limited in certain rooms by the brick walls as expected but works in my lounge fine.

 

If after a reset you cannot get the router to split frequencies call BT and check the routers not broke it sounds like there have been many dead on arrival.

 

when the HH6 works its a very OK router for the money, probably one of the best company supplied routers.

Don't get me wrong some of the router firmware sucks, like not being able to name a 5GHZ SSID anything other than "something"-5 but generally its OK.

 

Don't let all the negatives on this forum get to you, I am sure for every negative comment there are 100's if not 1000's of quiet happy users.