cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Crozzer
Aspiring Contributor
227 Views
Message 1 of 14

Port 5222 - XMPP Protocol

Go to solution

Hi,

 

I have recently bought an Epson ET-2650 printer. Now my pc can see it on the newtork and it can print fine. However, when I try and register it via the Epson connect setup utility, so I can register it and print remotely, it won't work. I have narrowed this down to the fact it requires port 5222 to be open which isn't. I have forwarded that port to my printer but it still remains closed, so I can only assume that BT are blocking it for some reason. Is anybody either able to confirm this, or point me in the right direction to get this resolved ?

 

Thanks !

0 Ratings
13 REPLIES
Expert Liam_
Expert
214 Views
Message 2 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

Assuming a Windows pc, have you checked that Windows firewall allows access via that port?

0 Ratings
Crozzer
Aspiring Contributor
202 Views
Message 3 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

Cheers Liam, that checks out ok.

 

 

0 Ratings
Distinguished Sage
Distinguished Sage
196 Views
Message 4 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

How are you testing the port to see if its open?

-----------------------------------------------------------------------------------

Forumhelp (Private website) Lots of additional information and help.
You will need to be connected to your home BT Broadband connection to view it, or any links to it that I post on this forum.

0 Ratings
Crozzer
Aspiring Contributor
190 Views
Message 5 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

I am using canyouseeme.org 

 

I have successfully tested other ports as follows:-

 

Port 5001 shows closed on canyouseeme

Port forward set up for this port to point to my NAS drive

Port 5001 now shows open

 

I have also done this with a few other ports successfully, but no joy with 5222, which is why I am guessing this is possibly a BT issue.

0 Ratings
Distinguished Sage
Distinguished Sage
182 Views
Message 6 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

BT do not normally block any ports, are you sure your printer is allowing incoming connections on that port, have you tested it locally on your LAN to see if the port is open?

 

I assume its TCP?

 

There is a Microsoft utility do do that.

 

-----------------------------------------------------------------------------------

Forumhelp (Private website) Lots of additional information and help.
You will need to be connected to your home BT Broadband connection to view it, or any links to it that I post on this forum.

0 Ratings
Expert Liam_
Expert
174 Views
Message 7 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

It may be that when you are checking the port the printer has gone into power saving mode, standby or whatever term Epson uses.

BT are not blocking the port  (5222).  The first image shows the port stealthed when the application used for testing is not running, like  a device in standby.

app not listening.png

 

Second image shows port 5222 open when the application is active and listening.

 

app running.png

0 Ratings
Distinguished Sage
Distinguished Sage
170 Views
Message 8 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

Use the Microsoft tool https://social.technet.microsoft.com/wiki/contents/articles/27661.portqueryui-gui-tool-that-can-be-u...

 

You can then test from your own LAN, into the printer.

 

-----------------------------------------------------------------------------------

Forumhelp (Private website) Lots of additional information and help.
You will need to be connected to your home BT Broadband connection to view it, or any links to it that I post on this forum.

0 Ratings
Crozzer
Aspiring Contributor
124 Views
Message 9 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

Thanks Liam - I have confirmed the printer isn't in power save mode / standby.

 

 

Thanks Keith - The results were as follows which shows something is filtering this port. I have turned off my router firewall and the windows defender one, to no avail. I also have the port forwarded still. I also have a MAC and that is the same, with either firewall off, or on with port access allowed. The .100 address is obviously the ip address of the printer.

 


Starting portqry.exe -n 192.168.1.100 -e 5222 -p TCP ...


Querying target system called:

192.168.1.100

Attempting to resolve IP address to a name...


IP address resolved to Epson

querying...

TCP port 5222 (unknown service): FILTERED
portqry.exe -n 192.168.1.100 -e 5222 -p TCP exits with return code 0x00000002.

0 Ratings
Distinguished Sage
Distinguished Sage
114 Views
Message 10 of 14

Re: Port 5222 - XMPP Protocol

Go to solution

The router firewall should have no function using portqry on your local network. I notice you have the printer IP address assigned by DHCP, which is not a good idea on a home hub.

 

Go into the front panel and give the printer a static IP, outside of the DHCP range. I have my Canon printer on 192.168.1.60.

 

That will overcome one of the issues with the DHCP server on the home hub.

 

Are you sure the printer used TCP and not UDP, as I have never bothered with remote printing, as it seems pointless as you cannot see what is being printed out.

 

I assume you can print out locally from your PC?

 

There are some strange issue with home hubs when it comes to sharing connections, which is one of the reasons I do not use one.

 

 

-----------------------------------------------------------------------------------

Forumhelp (Private website) Lots of additional information and help.
You will need to be connected to your home BT Broadband connection to view it, or any links to it that I post on this forum.

0 Ratings