cancel
Showing results for 
Search instead for 
Did you mean: 
hedderz
Beginner
684 Views
Message 1 of 13

Port Forwarding SmartHub6

Go to solution

Hi All

 

I hope this is a silly mistake on my part that I have missed but I can't for the life of me workout what I have done wrong.

 

I am trying to set up port forwarding but its just not working. I have set up a rule as follows

 

Capture.PNG

As you can see I'd like it that when I go to https://<my_external_IP> that I will get the the NAS management page. If I go to https://<my_internal_IP> then it works fine.

 

I have a few other services running on my NAS and I have setup similar rules that also don't work.

 

What have I missed? 

 

Thanks

 

Justin

0 Ratings
Reply
12 REPLIES 12
Liam_
Expert
667 Views
Message 2 of 13

Re: Port Forwarding SmartHub6

Go to solution

Hi,

Let's assume 443 is the only port required to be forwarded for your NAS and no others.

When you say 'As you can see I'd like it that when I go to https://<my_external_IP> that I will get the NAS management page.'

Where are you trying to connect from?

0 Ratings
Reply
hedderz
Beginner
641 Views
Message 3 of 13

Re: Port Forwarding SmartHub6

Go to solution
Yes 443 is the only port needed. Every other router I've had, I've enabled 443 inbound to my NAS and its worked.

I have tried from my laptop on my network (ie going out and back in) and also from a laptop not connected to the network (from a 4g connection on my phone, from my office network) all of which I could connect from when I was previously with Sky
0 Ratings
Reply
hedderz
Beginner
639 Views
Message 4 of 13

Re: Port Forwarding SmartHub6

Go to solution
I'll also say I am unable to ping my external address and if I use canyouseeme, the route does not appear to be listening on 443.
0 Ratings
Reply
Liam_
Expert
628 Views
Message 5 of 13

Re: Port Forwarding SmartHub6

Go to solution

If the router uses 'stealth mode' it won't respond to a ping.  I'd assume hubs do stealth, don't know as I never use them.

If you have set up FTP access as well you could try an FTP test site to check for access.  EG: http://www.infobyip.com/ftptest.php    or  https://ftptest.net/

You would also need to use a Dynamic DNS service to be able to access the NAS from a remote location.  I use

https://www.duiadns.net

It's very quick and simple to set up, supports both IPv4 and IPv6 and also has a client application to keep a server IP up to date.

0 Ratings
Reply
Liam_
Expert
621 Views
Message 6 of 13

Re: Port Forwarding SmartHub6

Go to solution

If you want to check your ports you can try here.

 

https://www.grc.com/x/ne.dll?bh0bkyd2

 

Click proceed and choose Common Ports, you should get a result something like this.

shields up.jpg

0 Ratings
Reply
hedderz
Beginner
602 Views
Message 7 of 13

Re: Port Forwarding SmartHub6

Go to solution

I use DynDNS. At first I thought the issue might be there but I checked the logs on DynDNS and can seen the hub talking to DynDNS and updating when I turn the feature off and on. Thats when I tried just using the IP. 

 

Here are the results

 

Capture.PNG

Here are my UPnP settings

 

Capture1.PNG

 

0 Ratings
Reply
Liam_
Expert
598 Views
Message 8 of 13

Re: Port Forwarding SmartHub6

Go to solution

The real question is did Shields up show the appropriate ports as open or Stealth?

For example 443 should show as OPEN if forwarded as should the rest of the listening ports you assigned.

Hubs tend not to do UPnP correctly most of the time.

0 Ratings
Reply
hedderz
Beginner
587 Views
Message 9 of 13

Re: Port Forwarding SmartHub6

Go to solution

Sorry, my bad. I just clicked the big button and didnt select common ports. As yiou can see, the router doesn't have open/listening for 443 inbound connections.

 

Capture.PNG

0 Ratings
Reply
Liam_
Expert
585 Views
Message 10 of 13

Re: Port Forwarding SmartHub6

Go to solution

Try 1 and only one, factory reset of the Hub, with a pin/paperclip in the little hole in the back.  Hold for at least 20 seconds, till the light flashes.  Then set up your port forwarding again.  You could also try giving the NAS a static IP.  You need to do that on the NAS, not by telling the router to always assign this IP, that's not static.  Routers can't set static IPs.

0 Ratings
Reply