cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,132 Views
Message 1 of 2

Port forwarding not working

I run an asterisk based phone system for personal use with several extensions, a couple on the local network, 1 on my mobile and a couple of physical IP phones elsewhere for remote access allowing one phone number to essentially follow me around.

With the previous smarthub it was working perfectly fine, however a smarthub2 was sent out and a demand for the old one to be returned was issued. Initially the smart hub 2 worked as the previous one with the port forwarding rules allowing remote extensions to register, however in the last few days, port 5060 is showing closed according to services such as canyouseeme and yougetsignal, and phones accessing through the external address are unable to register on the server.

I am confident it is not an issue with my server as registrations work fine internally, and no settings have been changed on it between it working externally and stopping working externally.

Basically, I need port 5060 of my public IP to forward to port 5060 of internal device 192.168.1.65. forwarding external port 5060 to another internal port, such as 80 [I.e. <externalIP>:5060 --> 192.168.1.65:80] for the GUI of the phone system (i know this is a bad idea, and was only for a matter of minutes as part of troubleshooting) does open external port 5060 and the gui will load through an external connection, but forwarding it to internal port 5060 closes the port again and no phones can register using the external IP.

I have tried changing the SIP port the phone system listens on, wondering if there is a block in place on external connections to port 5060 internally. Most recently changed to 200 and forwarding external 5060 to internal 200, and that also does not open the external port 5060. 

Additionally, i have tried disabling the router firewall, phone server firewall and both together, none of which had any effect in resolving the issue. Further to this i tried placing the phone server in the DMZ which again had no effect.

The only other idea i have on what could be affecting it is the new BT IP phone service that they are replacing analogue lines with - wondering whether the fact this router now connects to that is interfering with it, but i cant see any options in the router to disable that service.

It really shouldn't be this hard to do a relatively basic task, but i have spent several hours working on this across multiple days, and i am no further forward but starting to loose my mind. Therefore, i and am hoping there is someone in the BT community support who has come across this issue and found a solution that they would be willing to share. Or at least any further troubleshooting steps that i have overlooked.

Many thanks in advance for any assistance that you can provide

0 Ratings
Reply
1 REPLY 1
702 Views
Message 2 of 2

Re: Port forwarding not working

Hi,

 

Did you ever get this sorted?

 

im trying to get 3CX set up to serve as a second "business" phone line, but having the same issue as you ?

 

I was using a third party router last time I set this up but we use the bt digital voice for our main line now so don't think that is possiblw

 

0 Ratings
Reply