Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 8

Problems with Smart Hub 2 with address



1. I need to have the Smart Hub 2 router / gateway / dns address as, because Apple Devices will not connect to the internet by default if those addresses remain as the default (They connect to the network, but never to the internet.)

2. But if I do set the router / gateway / dns addresses to then the network is much flakier than when it's on 192.168.1. 254 — web sites won't connect, connections are dropped several times an hour, and even the safari link to to manage the router takes several attempts at loading.

So, there's obviously two problems / questions:

1. When the router / gateway / dns addresses are, it's not sending these details out correctly on dhcpd for the Apple devices to pick them up. But if this is the case then the internet would be alive with BT breaks Apple headlines and it isn't... So what do I need to change to get it working? What tests should I run to find the problem settings?

2. If the addresses are set to then clearly there's a problem with the settings causing the flakiness. Where should I be looking to diagnose the problem?

Many thanks.


More details: 

The problem is that no matter what I do, when I am setting up an Apple device, it will not connect to the internet with the router / gateway / dns set to — initial connection is made, but the next step (connection to Apple's servers etc) never takes place and the installation eventually times out. The only way of proceeding with the installation/setup is to change the router/gateway/dns addresses to -- and when I do that the setup immediately works with no problem.

This behaviour is repeatable and has caused problems with iPads, iPhones, and the internet reset of MacOS, and yesterday, the HompPod — every time without fail, installation/setup hangs until I change the router/gateway/dns to

I could just go with the flow and accept as the router/gateway address, but the problem is that the router is for some reason much less robust on that setting — it's definitely more stable with (though I have been unable to sort out why — all the other settings are as they should be).

It looks as though the Apple devices do not pick up the network router settings properly - in other words, it finds the network itself, but does not change the gateway/dns to as it should.

BTW I've had this problem ever since I received the Smart Hub 2, but changing the network addresses temporarily to, then back to (and then giving the devices static IPs so I can manually set the router / gateway / dns to worked well enough that I just lived with it. But now I've bought a HomePod and that option isn't available, so I need to fix the underlying problem...


Does anyone have any idea why this should be, and any suggestions to fix it?

Not applicable
Message 2 of 8

Re: Problems with Smart Hub 2 with address

Never heard of that one. I have an ipad and various friends and family have iphones, none of them ever have any problems connecting to my SH2 when they come round. What makes you think that ?

If you're 100% sure that what you say is true then you could try a class B address (say, don't forget to change the DHCP pool accordingly though if you do.

0 Ratings
Message 3 of 8

Re: Problems with Smart Hub 2 with address

"Never heard of that one. I have an ipad and various friends and family have iphones, none of them ever have any problems connecting to my SH2 when they come round. What makes you think that ?"

Bitter experience! It's something I've had to do about twenty times (new iPhone, iPad, recover MacOS, install BT TV, Apple TV etc on various occasions). It shouldn't happen, but it really does. There's clearly a mismatch in a config somewhere, but I can't find it, despite trawling through every advanced setting.

But aside from the dhcp issue, why is a network based on so flaky? It doesn't make sense, but it’s definitely the case. 

I've gone back to .254 now because .1 is unusable. Once I've got over the frustration, I'll try a B class network.


Message 4 of 8

Re: Problems with Smart Hub 2 with address

I have that problem with my iphone6s ios14.5 and it is non existent. Once a day I get home WiFi. I have to use my mobile data at home. Terrible. Older iPhone with iOS 12 has no problem. Did you find an answer?
0 Ratings
Message 5 of 8

Re: Problems with Smart Hub 2 with address


Do you have Private Addressing turned off on your iOS 14 phone for your home wifi? If not do so as this new function in iOS14 causes all sorts of issues.

Other options are :- Turn off Smart Setup and maybe the 5gHZ wifi as the same wifi SSID on both frequencies seems an issue with Apple devices.

Aspiring Contributor
Message 6 of 8

Re: Problems with Smart Hub 2 with address


That certainly sounds something Apple must have updated recently as I have an old MacBook Pro (but running virtually latest OS 11.4), a work MacBook Air, an iPad Pro (up to date), my wife has a Macbook and iPhone, and all work with the device set with standard .254 as gateway address with no problems whatsoever. 

I connect via wifi and cable, sometimes from the same devices (i..e both lan and wifi connected to the sh2). I also have a tonne of other devices connected. 

I'd agree, not sure why .1 would be a problem either as the DHCP/DNS. My only thought is what's your DHCP range assignment - if you changed it (and it can assign .1 to another device) again you may get collisions. Also, set a secondary DNS server on all your Apple devices of maybe or etc (free semi-secure dns) - that might make connections more stable. 

I'd suggest maybe 2-3 things (you seem to be pretty technical) - check the LAN & DHCP logs when setting to .1 or when apple devices are connecting and look for anything weird - likewise (admin on Mac) console logs. 

Also, on a device that works (wirelessly) like a tablet or phone, download 'fing' and scan your network (it's free) and scan for devices on your network and see if there's a clash (more than one device reporting itself on .1) - fing's pretty good at IDing devices too. 

Final thought - you don't have ANYTHING else that may be acting as a DHCP server on the same network do you (backup device)? I would expect that to cause issues on all devices and on either .254 or .1 but just in case... 

Hope you find a solution!

Aspiring Contributor
Message 7 of 8

Re: Problems with Smart Hub 2 with address

Oh, and one last thought, go clear out all the old Wifi networks you have on your Mac devices if you can (under network->wifi on Macs). I think you can do the same on iPads and iPhones.
Message 8 of 8

Re: Problems with Smart Hub 2 with address

I love your reply. Huge thanks. I will come back with result. By the way I went to an office and I could not believe that my above iPhone 6s+ actually was able to access and stay on Wi-Fi even to back up to iCloud about an hour. When home no chance. My old iPhone 6 and new refurbished iPhone X both access my home Wi-Fi.
0 Ratings