cancel
Showing results for 
Search instead for 
Did you mean: 
crashcourse
Beginner
601 Views
Message 1 of 20

Save button unresponsive for updating device settings

Hello,

I've just gone into my Smart Hub 2 for the first time in a few months, logged in with my administrator password, and tried to change a device name and icon. After making a change I get the usual 'Changes need to be saved!' alert, but then clicking the 'Save' button does nothing.

I've tried various browsers (Chrome, Safari, Firefox) as well as restarting the router. I've also noticed in the Chrome console complaining of an 'Uncaught TypeError' when pressing the Save button, so I'm pretty sure it's an issue with the device software and not a browser-specific issue.

I'm running a Smart Hub 2 with firmware updated in early June (v0.13.04.03282).

Anyone else having this issue? Any advice is greatly appreciated.

Thanks guys!

19 REPLIES 19
Moderator
Moderator
534 Views
Message 2 of 20

Re: Save button unresponsive for updating device settings

Hi @crashcourse,

Thank you for posting. I'm sorry it's taken so long to reply. Did you manage to get this resolved?

If you're still having problem updating the device setting, I'd like to get this investigated.

I have sent you a private message with instructions on how to contact me. You can access your messages via the envelope icon at the top right of the screen, or click on this link, Private messages

Thanks

PaddyB

0 Ratings
Reply
AustinSpeedy
Aspiring Contributor
488 Views
Message 3 of 20

Re: Save button unresponsive for updating device settings

I have exactly the same issue saving device names and icons, in some cases it worked but not in the majority.

0 Ratings
Reply
Highlighted
484 Views
Message 4 of 20

Re: Save button unresponsive for updating device settings

Hi @AustinSpeedy   The usual cause is using invalid characters in the name. For example I believe spaces are not allowed. 

0 Ratings
Reply
crashcourse
Beginner
473 Views
Message 5 of 20

Re: Save button unresponsive for updating device settings

I'm afraid the only solution in the end was to do a full factory reset and set up the router from scratch. The Smart Hub team are looking into why this may have happened, so I'll let you know when I hear back.

Alternatively you could try disabling javascript in your browser and hitting save (didn't occur to me at the time). However, it's possible that could cause issues.

@VeteranISPUser  spaces are allowed in this case. Essentially the save button was totally broken regardless of the changes you try to make (throwing JS errors on click).

0 Ratings
Reply
AustinSpeedy
Aspiring Contributor
453 Views
Message 6 of 20

Re: Save button unresponsive for updating device settings

It works in some cases, I can't see a pattern, for example I was able to change one device to Camera 2 but not another to Camera 1.

0 Ratings
Reply
ZooBurner
Aspiring Expert
434 Views
Message 7 of 20

Re: Save button unresponsive for updating device settings

I have the same problem, but when trying to alter the wireless password, or the router password, it simply won't save the changes.

This problem though goes back to the early firmware versions of the SH2, and with each firmware update I've been hoping it will be solved, but isn't.

0 Ratings
Reply
Moderator
Moderator
331 Views
Message 8 of 20

Re: Save button unresponsive for updating device settings

Hi @crashcourse  the Hub team wanted to check what/if any non-alphanumeric characters you may have used? Do you remember and if so would you mind letting us know?

@ZooBurner  Are you still experiencing this problem and if so are you using any non-alphanumeric characters?
Post back and let me know.

cheers
John 

0 Ratings
Reply
AustinSpeedy
Aspiring Contributor
320 Views
Message 9 of 20

Re: Save button unresponsive for updating device settings

As I said in a previous post, an example would be trying to change a name from an unintelligible s/n to Camera 1 having already successfully done the same thing for Camera 2. No special characters used.

0 Ratings
Reply
ZooBurner
Aspiring Expert
310 Views
Message 10 of 20

Re: Save button unresponsive for updating device settings

Hi there John. @JohnC2 

 

I've tried every imaginable way, non alphanumeric characters 4 different browsers*, with/without AV software in all combinations.

*Firefox, Chrome, Edge, Opera

I have managed to do it via the BT app on a smartphone though, just never through a PC (Both ethernet & wireless)

In a way I have solved the problem via the Android BT app but that's less than ideal of course,  I would be willing to try different things though out of curiosity as to what the cause is I simply can't think of anything else to try.

0 Ratings
Reply