cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
2,550 Views
Message 1 of 12

Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

Hi

Recently upgraded to BT FTTP and smart hub 2.

The house is wired up with CAT 5e or better so have an unmanaged 8 port Ethernet switch to distribute.

The router is working perfectly for wifi.

The router will send data to the switch but does not flow through it.

The Ethernet ports on the back of the router work if something is plugged directly into them.

I have spoken to the tech helpline and gone through various fixes with them but will not work still.

I have tried 3 brand new unmanaged switches  with the same result.

So in short, data flows out of the router but gets stopped at the switch.

Any ideas what could be stopping it?

Thanks in advance 

0 Ratings
Reply
11 REPLIES 11
2,516 Views
Message 2 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

I don't see any reason why it should not work. In fact, I used a Netgear GS108 switch for a few weeks on my SmartHub 2 until changing it for a GS116. Both work fine.

There are not many user changeable settings on the SmartHub2 when it comes to the LAN, so there's not really anything I can think of that you are doing wrong. You can see my settings below, if it helps.

Someone more knowledgeable may be able to provide more ideas. I just wanted to let you know that I use Netgear unmanaged switches and they do seem to work fine, so it shouldn't be a general issue.

Will168_0-1618563265355.png

0 Ratings
Reply
2,507 Views
Message 3 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

Thank you for the reply.

My settings are exactly the same.

The only thing I haven’t tried yet is a new smart hub 2. 
I can’t see any reason why it would make a difference if the ports are working on the current one but it’s the only part of the chain I haven’t swapped out yet.

BT suggested there may be an issue with the smart hub 2 and the switch.  They couldn’t be specific. They thought that using an old router may help.

It’s incredibly frustrating!

0 Ratings
Reply
2,471 Views
Message 4 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

While im sure you have already checked this i run two 8 port switches and when one failed it turned out the network cable had been damaged during a recent redecoration (the cable runs along the skirting board and when putting the wall unit back in place it had snagged somehow and pinched)

Replaced the cable and everything worked fine again

Does the switch have any kind of status light on it? (power, uplink speed, ect)

0 Ratings
Reply
2,427 Views
Message 5 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

Thank you for the reply.

The cable I am using currently is brand new and has not been properly installed yet as the set up is not working.

The cable from the modem to router is good - I am getting full speed via wifi. 

The cable to the switch is new also and I have tried a couple of new cables too.

This has me stumped.

0 Ratings
Reply
2,402 Views
Message 6 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

Same, in my experience switches are plug and play so i honestly don't know what else to say as a suggestion.

0 Ratings
Reply
2,393 Views
Message 7 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

I have FTTP, a netgear switch and a TP-Link one and it's been working for a couple of years or more with no problem.

A couple of things you might want to try if you haven't already.


A thank you is nice, it makes the effort worthwhile, but a kudo is better, by a country mile. (I'm no poet & boy don't I know it)
0 Ratings
Reply
2,025 Views
Message 8 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

Hi, did you get this sorted in the end? I have a similar issue but with the switch it’s on random ports they come to life then drop off again! I’m hoping to get hold of a new router to try 

0 Ratings
Reply
577 Views
Message 9 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

Hi,

I have just encountered the same issue as @Bundy21  who started this thread.

I have BT Home Hub2 that has been working fine for a couple of years.  It has been connected to an older Netgear unmanaged x16 switch and more recently also connected to another Netgear x8 switch (GS108).  Both of which have been working fine for a couple of years.

Following some DIY changes I have had reason to turn off power a few times and now the switches are not distributing data.  I know I have mentioned DIY, but I have double checked all cables and there are no breakages etc.  I can prove that data is flowing fine into the switch, but none of the devices attached to the switch receive data.  Like I say it is like the switch has stopped allowing data to flow out.  If the devices are connected to the cable feeding into the switch they also work.

Whilst troubleshooting with the GS108, I managed to get it working through some trial and error connecting and disconnecting the main data input with other devices in different orders.  But even that has stopped working. I had read somewhere that you should connect the source from the router first, then devices afterwards - is there any truth in this?

I have also read something about network looping that may cause the router to ignore connections via the switch.  I have not gone through the process of removing all connected devices yet, but that is probably the next step.

I have also experience what @Keniffsims did, were some devices were assigned a connection for a few seconds and then automatically disconnected.  One of my smart TVs would not shut up about being connected one minute and disconnected the next.

Lastly, I looked for the 'Smart Set Up' option on the BT Home Hub, but it looks like it no longer exists, so cannot turn it off!

Any advice, please.

0 Ratings
Reply
553 Views
Message 10 of 12

Re: Smart Hub 2 compatibility with netgear Ethernet switch

Go to solution

Since a recent Smarthub software update, "Smart set up" is turned off by default and is no longer shown in the management pages.

Have you tried a factory reset of the Smarthub by pressing a pin into the recess button on the rear for about 20 seconds?

0 Ratings
Reply