cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JB10
Beginner
824 Views
Message 1 of 4

Smart Hub 2's settings preventing Echo Show 5 connecting?

I received an Echo Show 5 for Christmas but it will not connect to my Smart Hub 2 - message says to check wi-fi settings. Having read some troubleshooting guidance I have turned off Smart Setup and also switched off 5 GHz wireless. I have also opened the TCP ports 55442, 55443 and UDP port 55444. Still no success. I have three Echo Dots that are connected without problem and other devices on the wi-fi are working normally, it is just the Echo Show that is problematical. Any suggestions appreciated. 

 

0 Ratings
Reply
3 REPLIES 3
TheSeasider
Contributor
781 Views
Message 2 of 4

Re: Smart Hub 2's settings preventing Echo Show 5 connecting?

Back to the Basics here ....

  1. You HAVE connected it to your Amazon Account haven't you ???  
  2. Is it showing up in your SH2 "Listings"
  3.  This may of assistance to you >>>>>> https://uk.pcmag.com/amazon-echo/90941/how-to-set-up-multiple-echo-devices-and-enable-multi-room-mus...
0 Ratings
Reply
al_may
Beginner
129 Views
Message 3 of 4

Re: Smart Hub 2's settings preventing Echo Show 5 connecting?

I turned off Extended UPnP security and it worked

0 Ratings
Reply
Les-Gibson
Recognised Expert
117 Views
Message 4 of 4

Re: Smart Hub 2's settings preventing Echo Show 5 connecting?

Deleted: I've just seen the date of the original post


       
                                                     If the Smart Hub 2 is BT's best hub yet then what does that say about its predecessors ?
0 Ratings
Reply