cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
EastExpert
Aspiring Contributor
905 Views
Message 1 of 4

Smart Hub 6.0A - Minor errors in the firmware

Hello,

I'd like to report some minor errors in Smart Hub 6A firmware, Version SG4B10002244. Also there'd be a few suggestions.

 

  1. Home > Advanced settings > Technical log
    1. Field Data rate: Units are incorrectly marked "kbps"; Mbps should be used.
    2. Field Maximum data rate: Units are missing. Correct unit is probably kbps.
    3. I don't understand why similar and related values Data rate and Maximum data rate are measured in different units. Should be the same to easily see how far actual speeds are below the current limits.
    4. Field Noise Margin and Line attenuation: Units there are dB.
    5. Field Signal attenuation: what is it? I know of no such parameters of DSL line, and there's no value.
    6. Field Data sent/received: Never saw figures in excess of 4096 MB, they seem to roll over that value. Probable reasons: int32 field is used for that count, whereas int64 is required to address more than 4GB of data. Or display format takes truncated value.
    7. The very name of this page, "Technical Log", is misleading; Only Event log tab has a technical log. Information tab doesn't contain a log, it contains mere information. Need to rethink that name, probably.
    8. Event Log tab:
      1. Save button is misleading, as almost everywhere else Save button is used to save edited parameters. There's nothing to edit on this tab. Suggested change: Save Log to CSV or Save Report.
      2. Date/Time Format is inconvenient, as date is hidden at the end of it. Suggested change: 2017-03-05 21:02:23. That allows to quickly visually see what portion of log are we scrolling through.
      3. Find feature would be really appreciated. Scrolling 160 pages of log, to find last reboot or IP address allocation? I don't think so...
  2. Home > Advanced settings > Broadband, Internet tab
    1. Field Data usage (both uploaded and downloaded) seems to have same problem as Data sent/received in Technical log: rollover at 4096 MB due to int32 use instead of int64.
    2. Field Connection time is not live. It is live, however, in Technical log... Lack of consistency here.
  3. Home > Restart the Smart Hub
    1. After restart, under Edge it asks for password (don't know about other browsers) and the web interface doesn't reconnect nicely, lots of refreshes are required. Not sure if this is just my problem or a common one.
  4. Home > Hub light control
    1. Suggestion: Fields Turn light on at and Turn light off at: Allow direct entry of numbers there. Having to click up/down control 59 times sucks. I could just enter number directly! Why not allow both arrows and direct entry.
  5. Home > My network
    1. Suggestion: While the device list is loading, indicate this by "Loading..." or other type of indicator. Otherwise one may incorrectly assume there are no devices connected to the Hub, while they are just being loaded. Since the loading takes quite a few seconds, progress indicator is required.
    2. Sort by: Device name set as default, -- yet on first visit to this page, there is no sort order applied, . I suggest executing the sort once the page completed loading.
    3. Sort by: IP address -- Sorts by textual IP address representation instead of actual IP address value. As a result, the address 192.168.1.64 appears AFTER 192.168.1.151. It is wrong. Use numeric value for sort parameter!
    4. Could not find the explanation of letter D in the bottom-right device icon corner. Other icons are explained in Help.
  6. Home > Broadband performance test
    1. Please let us just do the perf-test instead of creating a new fault... We sometimes test the speed without the need to complain about this. Please let the new fault be created only if we requested to!
  7. Home > Status
    1. "Click here to go to the BT Wi-fi web page" button leads to a page, where no controls to join BT Wi-fi are presented. Or if they are there, they are incredibly difficult to find. I wasn't able to join the good samaritan program where I'd allow external users to use a small bit of my bandwidth.
    2. Save button is misleading as it saves report as CSV (in fact, semicolon-SV) and there aren't parameters to edit, and hence, to save. Should read Save CSV Report or similar text.
    3. Not all fields are saved in that report.
  8. Home > Wireless and Home > Advanced settings > Advanced wireless
    1. The small QR Code purpose unclear, not documented on that page -- there's no [?] mark next to it.
    2. Not obvious that one should push the small QR Code preview to get a life-sized code.
    3. Field Separate bands is aligned to the right, breaking the layout.
    4. Field Password strength has no [?] button. The part of explanation in field Security password, starting "To help make your password as secure as possible..." should appear at that button.
  9. Home > Advanced settings > IPv6, Configuration tab
    1. Field Name -- How do you change it? There's no button. There may be elsewhere, but I don't know how to find it.
  10. Home > Advanced settings > Firewall, Port forwarding tab
    1. External ports Start/End and Internal ports Start boxes can't display the full 5-digit port number, only 4 first digits are visible. There is no way to see the fifth digit in them, as a red forbidding sign is displayed when you hover over these fields.
    2. Likewise, Rule name field is not fully displayed, and there's no way to see it in full due to the same red forbidding sign when you hover over it.
  11. Home > Advanced settings > Dynamic DNS
    1. Refresh button doesn't appear to refresh my host registration with NoIP service.
  12. Home and Home > Advanced settings pages
    1. The entire design, while nice and mobile-friendly, doesn't highlight the important elements. As a result, Advanced settings button , which is a gateway to a whole host of other settings, is the same colour as other buttons, which lead merely to 1-3 pages.
    2. Same applies to Back to home page button, which is completely lost among other, less significant buttons.
Cheers
Maximilian
Tags (3)
3 REPLIES 3
oakserver
Contributor
791 Views
Message 2 of 4

Re: Smart Hub 6.0A - Minor errors in the firmware

Excellent input and all valid changes that I would have liked to have seen.

 

However, I fear that if BT cant fix the major issues they will never get round to fixing the minor.

0 Ratings
Reply
EastExpert
Aspiring Contributor
769 Views
Message 3 of 4

Re: Smart Hub 6.0A - Minor errors in the firmware

Could be true! If traditional (address major things then deal with the trivia) method is to be used.

 

On the other side, minor issues are deterministic and much easier to fix -- easier to get brownie points, and (initial) feeling of progress and accomplishment. 🙂 Which is required to take a stab at really big problems.

Cheers
Maximilian
0 Ratings
Reply
gt94sss2
Aspiring Expert
746 Views
Message 4 of 4

Re: Smart Hub 6.0A - Minor errors in the firmware

Its a nice list but don't expect rapid progress.. BT have been aware of most of the issues you raise from before the official launch of the Smart Hub - and I know they have tried to fix some of them before but obviously not yet succeeded if you're still having the same issues..

 

At least we know that BT will keep on working on the firmware unlike some other hardware manufacturers I could name!

0 Ratings
Reply