cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
DocUpdate
Newbie
7,377 Views
Message 1 of 12

Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

I installed the new BT Smart Hub 6 last night. Having experience of BT hardware from the Frog upwards to HomeHub 4, 5 and now 6 I was pretty sure that this would be a simple swap out. However, it appears the hub is hardwired for IPv6 and by default set to Mode 1 for the wireless. Looking across the forums this is probably why most people are having issues. If you turn on Mode 2 then all IoT Devices will connect again. However, the issue with IPv6 causes many devices like Apple iPhone, iPad and so on to not be able to connect to the App Store or even see the network properly. I have BT Powerline devices in the house and these also screw up reducing the throughput massively.

 

It is possible that it has nothing to do with IPv6 BUT on my HomeHub 5 I turn this feature off and only use IPv4 where my HomeHub 5 therefore has no issues whatsoever.  This network issue can be seen at the basic IP Packet level as devices will not ping (even if hardwired) the hub or outside world or have ports blocked which should be automatically open.

 

I am sorry but this all points to major flaws in the firmware. Thus I would recommend staying away from this device and going back to Home Hub 5 if you can until BT has fixed 99% of these problems. I only hope that when BT updates Home Hub 4 and 5 with the mandatory IPv6 rollout that they do not cause issues for these devices as well.

0 Ratings
11 REPLIES 11
delboy-lee
Contributor
7,373 Views
Message 2 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

I have had the Hub 6 for two weeks & have no known issues with my Apple devices or access to the Apple Store. According to my Hub IPv6 is also available but not DNS activated ? My speed checks on Thinkbroadband confirm availability of IPv6 address ?
So far I am very content with my Hub 6.
0 Ratings
Distinguished Sage
Distinguished Sage
7,360 Views
Message 3 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

my hh6 is IPv6 enabled and I don't have any problems with my 3 ipad devices and also using mode 1



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Distinguished Sage
Distinguished Sage
7,358 Views
Message 4 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

@DocUpdate

 

if you only installed hh6 last night has firmware updated to 21EC?



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
DocUpdate
Newbie
7,346 Views
Message 5 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

I have no idea it was left for 10 hrs approx by which point I gave up using it and switched back due to all the problems with it. To confirm that these issues are not related to the WiFi specifically as I downgraded to Mode 2. Note that this change were due to legacy IoT devices and not because iPads etc could not see it. The issues experience were on 3 x tower PCs around the house and wired laptops all experienced the throughput issue. Specifically these all run Apple or Windows 10 OS, all patched and fully operational. Some use Poweline and some direct to the Hub. iPads/iPhones could not download apps from the app store but could see web pages. PCs/Laptops had a speed of less that 7MB/s drop compared to using the HH5 which that had above 40MB/s. I spent time carefully configuring all settings and even did this twice from factory. Once I removed the HH5 and then put back HH5 all problems experienced went away. The only noticable difference in all cases was the increased use of IPv6. Thus as I originally said it could be to do with this or bad firmware. However, I have not got time to sit down and troubleshoot on a work day. Thus HH6 will stay in the box for a few months now until it is more stable.  

0 Ratings
Distinguished Sage
Distinguished Sage
7,342 Views
Message 6 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

I have all similar devices working without a problem so it may be that your firmware was not up to date which is normal from other posts.  the firmware however appears to update within couple if days to firmware ending 21EC



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
DocUpdate
Newbie
7,231 Views
Message 7 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

@imjolly

 

Firmware version:           SG4B100021EC

Firmware updated:         12-May-2016

0 Ratings
Distinguished Sage
Distinguished Sage
7,224 Views
Message 8 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

same as my hub6  did yours come with that firmware?

 

so it all works for me so not firmware problem



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
DocUpdate
Newbie
7,216 Views
Message 9 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

My Smart Hub arrived last week with the new EC firmware pre-installed. Previously this was the state of things:

 

The firmware version has updated from SG4B100021D0 to SG4B100021EC

The GUI version has updated from 1.25.1 to 1.28.3

And the firmware update date has gone from 27/04/16 to 12/05/16

 

Note, that this is a multi-device wired LAN issue and NOT related to wi-fi. I have a massive set of IoT or Powerlan devices around the hosue which are wired or wireless. The issues relate to throughput which and endpoints connections. This is exemplified with apple devices and can also be seen with Windows 10 laptops/desktops. The problems I believe are down to the use of IPv6 being widely used now in this Hub. I also think the hub is unstable and buggy which does not help, probably related to IPv6 implementation. Going forward I am waiting on a firmware update before swapping out my old HomeHub 5 which fully works.

 

If you read every recent post I have found it is traced down to either a firmware or network bug which I beleive is related to above.

   

0 Ratings
barneyhairball
Aspiring Contributor
7,159 Views
Message 10 of 12

Re: Smart Hub 6 - IPv6, network issues, bandwidth, Powerline, Apple and IoT Devices

Do you have 2 IPv6 addresses?  I have and don't know why.  I only had one with Hub5. Can you help?  Ps, I don't even know what they are.

0 Ratings