cancel
Showing results for 
Search instead for 
Did you mean: 
cccis
Newbie
361 Views
Message 31 of 32

Re: Smart Hub - wifi network names problem - SOLUTION

Go to solution

This annoying name restriction is still present in the hub I received this month (May 2018). Many manufacturers standardized on -5G so why can't BT give that as an option?

Seems like they removed angularjs and went for more manual jquery, possibly for compatibility reasons? That's the reason why the angular command from before didn't work.

Based on @humps original post and @isoya modifications which worked for me, I've consolidated the instructions below:

1. Activate Chrome Developer Tools (or Safari or Firefox. They all have the equivalent debug console).

2. Login to the SmartHub admin page as normal with admin password, navigate to change wifi settings. Turn on the "Separate Bands" toggle so that you can type in separate SSID for 2.4 and 5Ghz.

3. Change a character or two in the 5Ghz's network name, so that the Save button becomes active

4. Click 'Console' tab of the Dev Tools panel to inject javascript commands to the webpage.

5. At the Console where '>' is shown, type the below, replacing MYSSID-5G with your own SSID and hit enter:

document.getElementById('wifi_Z2_input').value = "MYSSID-5G"

6. Click Save.

7. If it comes up with red pop-up as it warned my about password strength, it would have ruined the SSID. If you see the SSID is changed behind the red pop-up, repeat step 5 to re-correct the SSID before hitting 'Accept' on the pop-up.

8. Your desired SSID should be saved without and -5 suffix. 

0 Ratings
Reply
Highlighted
Ronnocod
Beginner
128 Views
Message 32 of 32

Re: Smart Hub - wifi network names problem - SOLUTION

Go to solution

Hi,

I have tried this solution but get error: Cannot set property ‘value’ of null at <anonymous>. Tried using Chrome and Firefox with same result.

 

0 Ratings
Reply