cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jr6218
Beginner
4,644 Views
Message 1 of 11

Smart plugs/bulbs

Go to solution

finally got mt services activated and happy so far. Only problem is I can't connect my smart bulbs and plugs. They run on 2.4ghz and I have the smarthub where you cannot seperate the SSID. I have turned off 5.4ghz and have turned off smart setup but no joy. 

Anyone found a work around for this? Spent a lot of money on the devices and don't want to replace them all! 

Any and all help appreciated 

0 Ratings
Reply
10 REPLIES 10
Keith_Beddoe
Distinguished Sage
Distinguished Sage
4,619 Views
Message 2 of 11

Re: Smart plugs/bulbs

Go to solution

@jr6218 

Based on what other people have posted on this forum, if you first turn off the 5GHz wireless on the home hub, then connect all of your smart devices and save the wireless settings on the devices, then turn the 5GHz back on, that seems to fix the issue with the Smart Hub 2.

Although smart devices do not normally have the ability to connect to 5GHz, the SH2 seems to get confused if 5GHz is initially enabled.

 

0 Ratings
Reply
jr6218
Beginner
4,614 Views
Message 3 of 11

Re: Smart plugs/bulbs

Go to solution

Hi Keith 

Tried that 5.ghz is off but still won't connect 

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
4,607 Views
Message 4 of 11

Re: Smart plugs/bulbs

Go to solution

@jr6218 wrote:

Hi Keith 

Tried that 5.ghz is off but still won't connect 


Perhaps the wireless mode needs changing on the SH2?

I have not used a BT home hub for a very long time, as I prefer to use my own router.

See if any other forum members have any suggestions, as I am sure the issue with the SH2 and smart devices, has been posted many times before, so a forum search may help.

 

0 Ratings
Reply
jr6218
Beginner
4,605 Views
Message 5 of 11

Re: Smart plugs/bulbs

Go to solution
I tried changing the wireless mode to but unsure what to change it too? Any ideas?

Thankyou for your replies!
0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
4,592 Views
Message 6 of 11

Re: Smart plugs/bulbs

Go to solution

@jr6218 wrote:
I tried changing the wireless mode to but unsure what to change it too? Any ideas?

Thankyou for your replies!

I seem to remember people mentioning it here. Try mode 2 or 3.

See this post https://community.bt.com/t5/Home-setup-Wi-Fi-network/mysterious-quot-Wireless-Mode-quot-setting/m-p/...

  • Mode 1: Gives you the fullest featured wireless, maximising speed and range
  • Mode 2: Some devices can sometimes struggle to use the latest wireless features. If you have any devices that can’t get a good wireless connection, try using this mode. Selecting this mode may reduce the wireless range and throughput but improve connectivity.
  • Mode 3: Change to this mode if your wireless devices don’t perform well using mode 1 or 2. Selecting this mode will reduce the latest features as well as wireless range and throughput compared to Mode 1 and 2. It'll enable the broadest range of devices to operate on the wireless. The features that are reduced include: power saving procedures, traffic aggregation methods and Multiple Concurrent data streams 
Mode Best for Compatible with Advanced features
1 Performance g/n and a/n/ac Y
2 Compatibility b/n/g and a/n N
3 Legacy b/g and a N
jr6218
Beginner
4,565 Views
Message 7 of 11

Re: Smart plugs/bulbs

Go to solution

Keith thanks for your help mate, you were right a forum search did the trick and found this. Followed your advice with the different modes and that may have had an affect as well 

 

Re: Smart Plug Connection

There is no need for changing anything on your router at all, or using extenders etc. 

The instructions on the apps and with the plugs are misleading and poor. The discovery can't simply work as the smartplugs out of the box have no idea which wifi network to connect to,  or any passwords etc so they cannot possibly get onto the wifi network, hence the discovery fails.

(The only reason extenders work is because the extenders have the login details for the network so the plugs don't need to know them to get on.)

When using the Apps (either smart life or Tuya smart)  Put the plug into pairing mode by holding the button in for 5 secs until it is flashing quickly. 

1) Press the + sign to add manually

2) Choose Socket

3) Select AP MODE at the top of the screen

It will then ask you to choose the network and password FOR YOUR HOME ROUTER.  When you enter this, it will go to your available wifi network connections and you select smartlife, rather than your home network to connect directly to the plug.

Once connected, the app will pass the network details to the plug which allows it to get onto your network. The app will then disconnect from the plug, reconnect to your home network and run a discovery where it will now find the plug as both the plug and app are now on your home wifi. Simply edit its details to give it a name and its now ready to be connected to the Alex/Google apps.

I hope I have made this clear. It looks complicated, but its actually very simple when using the app  and takes a minute to do. It's just very badly explained in the app.  I'm a network professional and it took me a good while to figure out what was going wrong

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
4,553 Views
Message 8 of 11

Re: Smart plugs/bulbs

Go to solution

I am pleased you have it sorted, it should help other people as well.

0 Ratings
Reply
KevinLee
Beginner
716 Views
Message 9 of 11

Re: Smart plugs/bulbs

Go to solution

Hi Keith,

After setting up my devices on 2.4GHz and changing the wireless back to 5GHz, will I loose all the devices that were connects with 2.4GHz? Just don't want to risk it in case I lost them as it took me forever to set them up. Thank you

 

0 Ratings
Reply
imjolly
Distinguished Sage
Distinguished Sage
714 Views
Message 10 of 11

Re: Smart plugs/bulbs

Go to solution

should be ok is you go by previous posts



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.