cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Pistolpehi
Aspiring Contributor
2,159 Views
Message 1 of 11

Smarthub 2 and NAS shares

I've seen similar questions to this, but never the same, or without a solution. I have tried some suggestions but to no avail.

I have a Smart TV wired into my Hub. I also have a NAS (Netgear ReadyNAS) wired into the hub which has several shared folders. About 3 BT Hubs ago, I was able to stream movies or music from the NAS to the TV as the atV could see the NAS and the shares.  Following various 'uplifts' to sort broadband speed etc. that ability disappeared.  I am now on the latest Smarthub 2 and it has the same issue as the last 2 or 3.  The TV can see the NAS but when I click on it, to see the shares, it says "Connection to the server failed'.  The only thing which has changed since it did work was the Hub, so the problem is there, but I can find no settings to help.

As there are not enough ports in the Hub for all my 'boxes', I have some plugged into a switch which plugs into the Hub.  The TV and NAS are not, but I have tried that, and that seems to make it worse, in that the TV can't see the NAS.

I have been trying to find the answer on and off for about 3 years. I have read all about the BT hubs being poor with DNLA etc.  I'm not overly technical so I don't know (or care) whether that matters.  I just want to know - IS THERE A SOLUTION TO THIS without the flippant answer of buying other kit.

0 Ratings
Reply
10 REPLIES 10
Anonymous
Not applicable
2,126 Views
Message 2 of 11

Re: Smarthub 2 and NAS shares

I'm guessing by your description that the problem is more likely to be with your TV than any number of different hubs, try going into your TV settings and reset (delete and start from fresh) your network settings

0 Ratings
Reply
Pistolpehi
Aspiring Contributor
2,112 Views
Message 3 of 11

Re: Smarthub 2 and NAS shares

Thanks for getting back to me.

I'd be interested to know what network setting in the TV could affect this.  

1. The TV is wired to the Hub.  Internet works

2. It recognises that the NAS is connected to the Hub, it is only when I try to connect to it that he connection fails.

3. The only thing which has changed since this all worked is the Hub

That said I'm always open to work things through at least to eliminate possibilities. However, for Wired access, there is nothing to set up.  The only thing that would be configurable is whether the IP address and DNS servers are obtained manually or automatically (and to key in addresses if manual).  I have always set these to Auto. I can change it to a static IP address, but is there any which would make a difference?

0 Ratings
Reply
Pistolpehi
Aspiring Contributor
2,057 Views
Message 4 of 11

Re: Smarthub 2 and NAS shares

Hi All

I'm still having no joy here.  Do I have to write this off as a weakness of the hub (and the previous two) or has anybody solved this problem or got more detsils that might get me to a solution?

0 Ratings
Reply
Anonymous
Not applicable
2,046 Views
Message 5 of 11

Re: Smarthub 2 and NAS shares

Your setup doesn't sound that different to mine except mine is a WD NAS and it works fine (touch wood)
0 Ratings
Reply
imjolly
Distinguished Sage
Distinguished Sage
2,041 Views
Message 6 of 11

Re: Smarthub 2 and NAS shares

you didn't say but have you turned off smart setup in the hub

http://bt.custhelp.com/app/answers/detail/a_id/44328/~/what-is-smart-setup-on-the-bt-hub%3F-how-can-...



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
Pistolpehi
Aspiring Contributor
2,031 Views
Message 7 of 11

Re: Smarthub 2 and NAS shares

Yes, I can confirm that Smart setup was and still is switched OFF.

0 Ratings
Reply
MattDu
Aspiring Contributor
1,973 Views
Message 8 of 11

Re: Smarthub 2 and NAS shares

For me it was the homehub. Although I did have an issue where the readynas wanted to set its own ip address(easy fix).

I have 3 Netgear ReadyNas and for months I've updated/reset and searched forum for stuttering and connection problems.

Replaced my Homehub with an openreach modem and netgear router and "it just works".

*Be warned, BT have figured out that openreach modems work flawlessly  without any problem, so they are phasing them out.*

0 Ratings
Reply
Pistolpehi
Aspiring Contributor
1,960 Views
Message 9 of 11

Re: Smarthub 2 and NAS shares

You are confirming what my belief is which is that the problem is the Hub.  I was hoping that someone would come up with a fix with the Hub rather than replacing it as I have the extra disks linked to the Hub to get the best wi-fi througout the house.  It's true that another solution may solve that issue, but that's an unknown.  So my quest for a solution from this Hub goes on.  Needless to say, you can't get anywhere with BT on this - it's such a shame that they have made so many retrograde steps with the Hubs over the years, taking out features with little improvement all round.

So still looking for an answer if anyone has one.

 

 

0 Ratings
Reply
MattDu
Aspiring Contributor
1,941 Views
Message 10 of 11

Re: Smarthub 2 and NAS shares

BTW My BT Openreach Huawei  HG612 Modem,version 3B, was £10 on eBay a couple of months ago  

I still had my old  AC router a Netgear R6300 that I bought for £30 on Gumtree, 3 year ago.

So £10 for a few months of everything working was a very good deal for me. Piece of mind. Scratched that itch long enough.

 

P.S. A week after solving the problem, I upgraded to a Netgear AX80, a little bit faster and future proof but mainly because it's more stable with the ever increasing number of WiFi connected devices. Echo, Hue, Hoover, Blink, Hive,  etc. £200 eBay merchant. Birthday present from my wife. Optional extra.

0 Ratings
Reply