cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Paul_RS
Aspiring Contributor
1,033 Views
Message 51 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution

If you have a BT disc(s) set up, unplug it. Then set up your wireless printer. You can plug the disc back in afterwards. I had a problem with my printer set up and that cured it.  The printer was presented with 2 identical networks, unplug the disk and the set up sees only one.  

Cheers

Paul

Bramshot
Contributor
934 Views
Message 52 of 65

Re: Sonos and Smart Hub2 connection issues it connect to Sonos to do so

Go to solution

Just installed Smart hub 2 and one disc as old router ( non BT) was starting to get a bit slow. Used to have BT hubs but had no end of trouble with them so I didn’t use the one I was sent until now. Surprised,  it mostly works but then hit the inevitable snag with Sonos as many here seem to have as well.

My disc connects my media server into the network via ethernet input to the disc ( that works),  same disc connects to my Sonos Move by wifi, app ( on pad connected to disc by wifi )connects to Sonos, Sonos will play from the server, but will not connect to the internet or play internet radio. There is no ethernet socket to connect Sonos Move to the router to try out that idea mentioned numerous times above. And I can’t find anything in the Sonos app to redo the wifi connection ( it tries to verify the app version but cannot connect to Sonos ‘central’ to do so). Any ideas or is this just a continuing failure by BT to produce a good router.

0 Ratings
Reply
buckdenjoe
Beginner
921 Views
Message 53 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution

 Since I started this thread all those years ago I have read all the messages with increasing interest.  By way of an update and for your information I have increased my Sonos kit by two items.  The first is a Sonos boost.  As those who have one of these will know this is hard wired into the Smart Hub.  All my other Sonos kit (Playbar, 2 Play 1s and Sub in lounge and 2 play 1s in kitchen) link to that.  To date my system has worked fine with no issues as a consequence of any router firmware upgrades.  My second item is a Sonos Move.  This connected fine initially.  Then, a few day later, upon opening the Sonos app on my Mac, the Move wasn't shown in my the system.  It worked fine with bluetooth but wifi no.  The only way to reconnect it was to move the Move(!) close to the router and reset it.  Reconnection.  A few days later, no connection and repeat.  Going into the router settings I find the  Move does NOT connect to a Sonos boost but connects like any other device to either 2.4 GHz or 5GHz.  Furthermore, it only shows up in the Sonos app if connected to the 5GHz band.  With the 2.4 Ghz it does not show at all so doesn't work.  It is fortunate the the wifi extender discs (I have two) both seem to use the 5GHz band otherwise it would have been a real pain having to reset the Move every couple of days.  This has been my experience with a Move to date and I hope this information is helpful.

0 Ratings
Reply
Bramshot
Contributor
898 Views
Message 54 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution

Thanks buckdenjoe

As I mentioned mine seems to be connected to the app no problem and it shows as connected in the Smart Hub device list, it works fine on the internal network, but can’t seem to get an internet connection, can’t use Internet radio.

It worked perfectly with my previous TP Link router, not sure if it connected via 2.4 or 5 Gig with that. There doesn’t seem to  be any way to tell what a device is connecting to other than by looking in the detailed device list, what basis is used to determine which band a dual band device connects to? Previous router showed 2 SSID’s and I could select which to connect to.

0 Ratings
Reply
Rod111
Aspiring Contributor
852 Views
Message 55 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution

BT complaints called today and whilst there wasn’t an update on when things would be resolved, the guidance was it was being treated as an unprecedented situation and there was teams working on a fix. They were unable to give a timescale. They advised against the complete Wi-fi disc fix of plugging a speaker into Ethernet, however they did agree to a £99 bill credit to cover the cost of purchasing a Sonos Boost. 

Separately, Sonos support emailed today to say they had had an update from BT that they were anticipating a fix in 4-5 weeks time. They asked for details of my router firmware version, when it was updated, and the serial. They advised they were passing this on directly to BT to ensure these users could be prioritised for a fix being pushed out. Interestingly the date of last firmware update has changed from 8-Apr-2021 to 4-May-2021, however the version is still unchanged. The issues also persists, so I don’t think anything has changed. 

JKenn
Aspiring Contributor
836 Views
Message 56 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution
Thanks!
0 Ratings
Reply
Bramshot
Contributor
815 Views
Message 57 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution

Sonos Move has now started to work correctly and now gets internet radio. Al I have done in the meantime that might have had an effect was succeed in reconnecting a recalcitrant Alexa and turned Smart wifi off on both channels, setting them manually to the automatically selected channels.

0 Ratings
Reply
Nomadski
Beginner
790 Views
Message 58 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution

I find it ridiculous that BT should push out an update that makes devices on different bands unable to talk to each other properly.  

I've had (since v0.26.03.01286 got pushed down to my router in early April) constant problems with Sonos not appearing on some or (at times) all of my devices.

The only solution has been to turn off the 5Ghz band on the router. Which works for Sonos, but leaves the rest of my wireless devices running at a slower speed.

Sonos forums are full of threads about this, and it seems BT has a fair few threads about this update, yet rather than rolling back they have just left it to us to troubleshoot what is happening with our home tech.

It's good to hear some are receiving updates, but having just done a reboot I'm still stuck on v0.26.03.01286 and 2.4Ghz.

0 Ratings
Reply
mavmeld
Aspiring Contributor
784 Views
Message 59 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution

Have you tried (are you able) to connect one Sonos device to the router by ethernet cable? That appears to be the most reliable fix until BT address the issue long term.

0 Ratings
Reply
Nomadski
Beginner
775 Views
Message 60 of 65

Re: Sonos and Smart Hub2 connection issues

Go to solution

@mavmeld My Play 5 is always hardwired to the router anyway. Doesn't help the situation unfortunately.

I did so much troubleshooting on this before I found out the cause was this update and knocking off 5Ghz was the only solution. I tried resetting the whole Sonos system, speaker by speaker, and leaving all but the Play 5 off but nothing worked.

0 Ratings
Reply