cancel
Showing results for 
Search instead for 
Did you mean: 
359 Views
Message 1 of 5

Switch not passing internet since upgrade to SmartHub

My BT Router is in the lounge and has 1 connection to the Sky Box, and 1 connection to a cable that runs upstairs and into a Netgear 5 port proSafe gigabit switch. 

 

From the switch I have my PC, PI, Laptop, TV all running from the switch.

 

This home network worked fine on my HomeHub 4.

 

Just before christmas we upgraded to fibre broadband, and got sent the Smart Hub. I swopped the router out for the new smart hub.  I then noticed that the PC was getting no internet, so after swopping cables etc I narrowed it down to the switch, if I plugged the cable in the office directly into the PC or TV it worked fine with fast broadband. If I went via the switch, then there was no internet. So I put it down to a faulty switch and purchased a new one. But I had the same problem, router -> switch -> PC = no internet.  router->PC = internet.

 

 

Just to be sure I hadnt had back luck and purchased a duff switch. I tried it in work and it performed fine.

 

So for some reason the BT Smart Hub does not allow me to have a switch on the network, it seems to block traffic going via the switch, but I have no idea why this would be.

 

I have disabled Smart Setup and this has not fixed anything, BT tech support couldnt help and said I need to talk to BT Tech Team which is a paid for service. Irony is if the sales person hadnt talked me into upgrading to fibre, i wouldnt be having an issue as I would still be on the HomeHub4.

0 Ratings
Reply
4 REPLIES 4
Distinguished Sage
Distinguished Sage
352 Views
Message 2 of 5

Re: Switch not passing internet since upgrade to SmartHub

There is no reason for a switch to do that. I know the smart hub works through a switch, as there is one at my daughter`s house which works just fine.

 

Have you tried connecting the switch directly to the home hub using a short Ethernet cable to see if it works, as it could be the length of the cable running upstairs which the hub does not like?

 

 

0 Ratings
Reply
Highlighted
Distinguished Sage
Distinguished Sage
339 Views
Message 3 of 5

Re: Switch not passing internet since upgrade to SmartHub

Bit of a long shot, but if it is a managed switch you could try setting the port speed to 100M full duplex rather than auto.

smf22
Recognised Expert
325 Views
Message 4 of 5

Re: Switch not passing internet since upgrade to SmartHub


@licquorice wrote:

Bit of a long shot, but if it is a managed switch you could try setting the port speed to 100M full duplex rather than auto.


@licquorice You should not set the port speed and duplex on only one of the two 'link partners'. With only one of the two partners hard set, the device that's still using auto-negotiation i.e., the Hub, will believe the switch to be incapable of auto-negotiation and will default to operating in half duplex mode. The result is a 'duplex mismatch' which will see very poor performance when the link starts to carry traffic.

 

@sankesolutions What type of UTP cable are you using and does it have all four pairs terminated? The HH4 only had one Gigabit Ethernet port (port 4) and unless you were using that port the speed would have been Fast Ethernet and so more forgiving of poor cabling. 

 

Are you able to try a different cable, ideally Cat 5e? I appreciate the cable is long, but perhaps move the switch next to the Hub as a test and use a shorter cable.

 

When connected are there any LEDs lit on the Netgear switch? If yes, are there one or both lit?

 

Regards

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
308 Views
Message 5 of 5

Re: Switch not passing internet since upgrade to SmartHub


@smf22 wrote:

@licquorice wrote:

Bit of a long shot, but if it is a managed switch you could try setting the port speed to 100M full duplex rather than auto.


@licquorice You should not set the port speed and duplex on only one of the two 'link partners'. With only one of the two partners hard set, the device that's still using auto-negotiation i.e., the Hub, will believe the switch to be incapable of auto-negotiation and will default to operating in half duplex mode. The result is a 'duplex mismatch' which will see very poor performance when the link starts to carry traffic.

 



Yes, good point.

0 Ratings
Reply