cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Aspiring Contributor
4,487 Views
Message 1 of 10

Synology NAS not showing in the home network with BT Home Hub 6

Go to solution

Hi all,

 

not sure if anyone can give any advice.

 

I have been struggling with my DS213J since I ugraded the my BT home hub to smart hub 6.

The NAS is quite old I know, but it has served me for years with my previous BT home hub version 4 without any issues. 

Since I upgraded to Home hub 6, I realised that some of the devices (like TV, network streamer) cannot find the NAS server if they are wired to the network, but if it's connecting through wifi, it would then work properly without issue in most of the cases (not always, like it was working with wireless connection yesterday but not today for some reason)

I have upgraded the DSM on NAS to the latest version (6.2.1) .

 

There are four lan ports on the back of Home hub 6, my NAS is connected to one of them. the other lan port is connected to one of my TVs in the lounge, the other two are connected to two separate netgear gigabit switches and have several devices connected to them. 

 

One Naim unity and one Cambridge audio CXN streamer are connected to one of the switches, they cannot see the NAS (diskstation).

 

The TV connected to the lan port on the back of Home hub directly can see the NAS server, but cannot access to it. However, if I switch the TV to connect through wireless network, it would then connect to the NAS without any issue. (But again it worked yesterday but not today!)

 

These devices all work fine with the previous Home hub 4 and could connect to the NAS without any issue. 

 

I have set the NAS to a static IP address outside the DHCP range set on the home hub, but it doesn't help.

 

When I viewed the device list on the media server on the NAS, I don't seem to find the above devices listed yet. 

 

Not sure if this is the reason? But I don't really know why they are not listed as all the devices are in the same subnet.

 

I have two wifi extenders in the house, all the devices connecting to one of them can find the NAS without any issues, while if the device switch to the other extender, it then cannot find the NAS at all.

 

It's quite a strange issue. Any one have had similar issues or can provide any advice? Is it anything wrong with my home hub?

 

Thanks very much!

 

Rick

0 Ratings
Reply
9 REPLIES 9
Highlighted
Distinguished Sage
Distinguished Sage
4,462 Views
Message 2 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution

There have been other reports on this forum about the visibility of devices on the HH6, with no real solution posted.

Can you not simply go back to using the HH4, as the HH6 offers no specific advantages, unless you have just upgraded  from ADSL to VDSL?

If you cannot resolve the problem, then you can get a third party router for about £40 upwards, that does work.

 

0 Ratings
Reply
Highlighted
Recognised Expert
4,449 Views
Message 3 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution

If all the devices are in the same subnet then the only thing I can think of is within the Media Server app (DMA Compatibility) on the DS have you :-

A. Reset the device list?

B. Cleared the "Restrict access to Media Server for newly detected uPnP/DLNA devices" check box?

and then let everything reconnect.

I don't use HomeHubs so I've no idea as to what settings in them might affect this.

Personally I always set my permanent devices to fixed IP Addresses either by setting it in the device or assigning it a fixed IP within the router.

 I had a DS212J before upgrading to a DS214Play & my son currently has the DS213J like you , but we both use Asus DSL-AC68U routers.

0 Ratings
Reply
Highlighted
Aspiring Contributor
4,437 Views
Message 4 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution
Hi Tim,

Thanks for your information.

Yes I have tried that as well. It’s always the devices connected to one of my extenders come in first, almost instantly and then the devices connected to the home hub Wi-fi come in about a day or two, but never the devices connected to lan ports on the back of the home hub. Very strange, isn’t it?

Thanks very much! Rick
0 Ratings
Reply
Highlighted
Aspiring Contributor
4,436 Views
Message 5 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution
Hi Keith,

I presume the hh6 should have faster lan ports ( gigabits) and Wi-fi connections, if it works properly ;-(

Could it be the particular hh6 I received faulty?

Thanks, Rick
0 Ratings
Reply
Highlighted
Recognised Expert
4,406 Views
Message 6 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution

Try plugging the DS into one of the Netgear switches.

0 Ratings
Reply
Highlighted
Aspiring Contributor
4,387 Views
Message 7 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution

Hi Tim,

 

Thanks very much fo ryour tips, that's a very good suggestion I never thought of... 

 

You are a star!! 

 

I connected the DS to one of my Netgear gigabits switches, now all the devices connecting to that switches can see DS straight away. At least now most of the devices I need the DS for are connected.  But funny enough, the devices connected through wift to the home hub directly cannot see the DS now ... 😉

 

I looks like the HH 6 is really a buggy one. Nevertheless I have a work around now. 

 

Thanks and all the best!

 

Rick

0 Ratings
Reply
Highlighted
Recognised Expert
4,382 Views
Message 8 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution

@Rick76

That's very odd.

With the DS connected to the Netgear switch I'd guess that any traffic to it won't be going through the HH6 so let's try to find out why the wifi devices won't see it.

Do you use DHCP for all devices or are they manually assigned , either in the device itself or in the HH6 as fixed IP addresses?

What is the IP pool range set for DHCP auto assignment?

If devices are manually assigned what range are they in?

What is the IP address of the HH6 eg 192.168.1.254 and what is your subnet mask?

Are the Netgear switches managed or unmanaged?

Do you have a wireless laptop that you can try to see the DS via Explore, not by a media viewer?

That's all I can think of to ask at the moment.

0 Ratings
Reply
Highlighted
Aspiring Contributor
4,368 Views
Message 9 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution

Hi Tim, 

 

Thanks for your help, here are my answers to your questions:

 

Do you use DHCP for all devices or are they manually assigned , either in the device itself or in the HH6 as fixed IP addresses?

== Yes, DHCP for all deivces apart from the DS (192.168.1.18)

What is the IP pool range set for DHCP auto assignment?

== 192.168.1.64 to 192.168.1.253 (the default setting on HH 6)

If devices are manually assigned what range are they in?

What is the IP address of the HH6 eg 192.168.1.254 and what is your subnet mask?

== yes, HH6 is at 192.168.1.254 and subnet mask is 255.255.255.0 - again the default setting

Are the Netgear switches managed or unmanaged?

== swiches are unmanaged.

Do you have a wireless laptop that you can try to see the DS via Explore, not by a media viewer?

== yes, connection to DS via explorer is acutally fine from all the computers in the house - in fact if I run Synology assistant on the computer and do the scan, they can find the DS and says it's ready - so the pysical connection to the DS is fine, it's just not appearing as a media server - If I connect my iPhone through one of the netgear wifi extenders (which is currently the most realiable one with DS), iPhone can find the DS straight away through VLC player - but if I switch it back to the HH wifi, DS will then disappear straight away.

 

It's something to do with the HH maybe but so far I'm happy now with the temp solution as it's at least working with my most of the devices that needs the DS. 🙂

 

Thanks, Rick

0 Ratings
Reply
Highlighted
Aspiring Contributor
4,365 Views
Message 10 of 10

Re: Synology NAS not showing in the home network with BT Home Hub 6

Go to solution

Hi Tim,

I was wrong with one thing. 

If fact, my iPad and one of the laptops which used to connecting to the DS through HH WiFi can still see the DS, but not the iPhone though.

 

looks like the WiFi part of the HH is better than the Ethernet part. 🙂

 

thanks, Rick

0 Ratings
Reply