cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Aspiring Expert
1,683 Views
Message 11 of 17

Re: The Mystery of the Smart Hub and the Printer

If you did this (attempt manual address configuration), you'd really want to use an address outside of the router's DHCP range, but on the same subnet to avoid IP address clashes.

The router configuration to find this out will be somewhere like:
Advanced ->Home Network -> IP Addresses -> DHCP Network Range

Supposing the range is 192.168.1.8-192.168.1.200, then pick address 192.168.1.201.

This would only be necessary if the printer was connecting to the network and failing to get a DHCP address or you wanted the printer to have a static IP address. Not recommended for most home users.

0 Ratings
Reply
Highlighted
Aspiring Expert
1,674 Views
Message 12 of 17

Re: The Mystery of the Smart Hub and the Printer

One more suggestion as you've moved flat and haven't already looked this:

 

You could installing an app on your phone, like WiFi Analyzer (others exist), that'll show you the WiFi Signal strength wherever you are in the flat with your phone.  Check what the signal strength of the WiFi is like next to the printer. If it is weak, you could try re-orientating your router or moving it temporarily. WiFi signals do not radiate equally in all directions and there's attentuation from walls and other internal structures.

 

Good luck!

0 Ratings
Reply
Highlighted
Aspiring Contributor
1,666 Views
Message 13 of 17

Re: The Mystery of the Smart Hub and the Printer

Thanks flamethrower, so helpful, I'll have a go at all of your suggestions and let you know how I get on.

 

I did trymoving the printer around the router (within a 1m radius) but will see if I can find a stronger signal.

0 Ratings
Reply
Highlighted
Aspiring Expert
1,642 Views
Message 14 of 17

Re: The Mystery of the Smart Hub and the Printer

Sorry, I know it was in the original post by I mis-read it as 50m not 50cm, BAD EYESIGHT :-). Within 1m, maybe the signal is too strong though seems unlikely.

0 Ratings
Reply
Highlighted
Aspiring Contributor
1,625 Views
Message 15 of 17

Re: The Mystery of the Smart Hub and the Printer

No worries.

 

Thanks again for all of your suggestions - tried everything and no luck so far. Just one of those weird quirks I guess.

 

Think I'm probably going to swap out the smart hub for a decent router at some point so I suspect that will solve the issue.

0 Ratings
Reply
Highlighted
1,587 Views
Message 16 of 17

Re: The Mystery of the Smart Hub and the Printer

Hi

 

I had a similar problem when I tried to get my HP printer to connect to my new Smart Hub.

 

When I went into the hubs home page I could see that it knew the printer was there because it showed an unknown device with the printers mac address, but it wouldn't allocate it an ip address.

 

After much googling I found somebody who had had the same problem with an HP printer but with a different router. In his case the problem was that the router name contained a space, and the printer didn't like it. He got rid of the space and it worked.

 

As you will be aware the smart hubs ssid doesn't have a space, but is quite long, and I think it has an hyphen.

 

Out of desperation I changed the the name to abthub, simple, no capitals, no numbers, no punctuation.

 

The printer connected an its first attempt and has worked perfectly since then.

 

Hope this helps

0 Ratings
Reply
Highlighted
95 Views
Message 17 of 17

Re: The Mystery of the Smart Hub and the Printer

I had this exact issue (with both my 2.4GHz Printer and Laptop! I actually bought a 5GHz Wifi Dongle) - but I have just solved it! - Was using a BT Smart Hub - Type A
I tried many ways to fix this and I wish I read this first! So responding this here for any future people like me.

Printer listens to 2.4GHz band.

On the hub - in wifi, in advanced settings - select "dual band" wifi.

re sync my phone to the 5GHz band (which now has an appended SSID)

Then using wifi analyser free app on my phone I optimised the wifi channels to give maximum signal at the printer position (and also my Laptop in the other room on 5GHz) etc

Then turn off the printer.  Then Disable 2.4GHz band on the Hub.

Check it was disabled on the Analyser (it can take a few seconds).  Then Re-enable the 2.4GHz Band. Check it is back and signal is good on the Analyser. Then printer on - immediately it remembered the password from before and connected.