cancel
Showing results for 
Search instead for 
Did you mean: 
Steveharman
Beginner
42,496 Views
Message 1 of 12

Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

Hi,

 

I'm trying to move away from the HHub5 on our FTTC BT Infinity connection (40Mb/s). Eventually I settled on a TP-Link WDR 3600 N600 - the flavour which is happy to talk to cable modems and take an OpenWRT install.

 

So far I've hooked up a BT OpenReach "white box" modem using the HHub's RJ11 lead, going from the DSL filter into the OpenReach modem's DSL socket.  The modem's DSL LED lights up solid green - which I presume is good?  The TP-Link router is up & running fine with OpenWRT installed, I can connect to it over WiFi and I've hooked up its WAN connection to the OpenReach modem's LAN1 socket (LAN2 is blanked out).

 

But whatever I put in the router's PPPoE settings I just can't get an internet connection to come up.  So far I've used 'bthomehub@btbroadband.com (as it's set on the HHub) and a few other suggestions from the forums including 'anything you like' @btinternet.com and @btbroadband.com - nothing seems to get the connection going.

 

Is there something I've missed or can anyone suggest a solution?

 

Many thanks,

 

Steve

Tags (2)
0 Ratings
Reply
11 REPLIES 11
Distinguished Sage
Distinguished Sage
42,484 Views
Message 2 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

bthomehub@btbroadband.com is the correct username and although BT don't require a password your router may do. Just enter BT as the password.

0 Ratings
Reply
Highlighted
Steveharman
Beginner
42,483 Views
Message 3 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

Sorry to answer my own question, but in case it helps anyone in the future:

 

I had to put my username in the username AND password fields - same details in both.  I've not seen this written  anywhere online, everyone says to leave the password field blank as it's unused.

 

So to recap - this is what got my TP-LINK WDR3600 (OpenWRT based) router working with Infinity: stick homehub@btbroadband.com in the PPPoE usernamd AND password fields.

 

Steve

mines
Aspiring Contributor
42,448 Views
Message 4 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

I too have the same router that I used to use with my cable provider. I now have the home hub 5 in standalone.

Can I use any modem or does it have to be supplied by bt to get my tp-link to work again?

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
42,443 Views
Message 5 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

Any VDSL modem will do , but there are very few standalone VDSL modems. Other than an Openreach modem from an auction site, there are the Draytek Vigor 130 at about £75 or the Zyxel P871M at about £130

0 Ratings
Reply
CirenJules
Beginner
42,153 Views
Message 6 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

When previously on Sky aDSL, I ran a Draytek 120 modem and ASUS N66U running Merlin firmware. After moving to BT Infinity 1, I wanted an alternative to the HH5 so upgraded to a Draytek 130 VDSL modem and ASUS RT-87U running Merlin RT AC87U_378.56_2 firmware.

 

Like many other people, the issue I had was that the HH5 worked fine with streaming services including BT TV, BT Sport and iPlayer etc. via YouView - but the ASUS didn’t; I kept getting the dreaded IPC 6023 even though the LAN info. was right and the displayed YouView time/clock was remained accurate.

 

After spending many hours researching and then resolving this issue, I wanted to share what I learnt including the ‘must do’ steps which worked for me:

 

  1. The Draytek130 and ASUS routers do work with Infinity1 and YouView for both BT TV/Sport & the Players
  2. A fundamental point is for separate modem/router configurations, do not to forget about your modem set-up as well as your router
  3. The BT YouView services are based around multi-cast which in turn needs igmp-related services to be running on your IPTV compatible router
  4. ASUS introduced a bug into a past version of their vanilla firmware which specifically affected only PPPoE and which resulted in a zeroconf error; meaning that igmpproxy-services didn’t start. Merlin unknowingly inherited the bug but then worked with others to fix-it (thank you Merlin http://www.snbforums.com/threads/asuswrt-merlin-378-54_2-is-now-available.24902/page-6). The latest versions of the ASUS vanilla and Merlin are both good 🙂  See screen shots for version.
  5. Steps:

a. Log-on to your ASUS router as Admin
b. Check your Firmware version; upgrade if necessary but before doing so take screen-shots of each config. page if you’ve got a complex configuration; back-up the Conf. too
c. Once you’ve upgraded the firmware, do a manual hard reset back to factory using the button on the back of the Router
d. Do not be tempted to load any previously saved router configurations; start clean
e. Log-on to the Router as Admin – on the various sections/tabs:
    - ASUS LAN - Router needs to allocate a fixed LAN IP to the YouView box:

ASUS_IPTV_Static IP.png

     - ASUS LAN – IPTV settings:

ASUS_IPTV_IPTV.png

      - ASUS WAN – apply a number of Forwards to the YouView box:

ASUS_IPTV_Forwards.png

 

6. You may not need all the above Forwards, but I’ve just had enough playing around with this and now have a configuration that works! Someone commented that these worked with an earlier BT Vision and they just kept them when they went to BT TV

 

7. You have to disable DHCP+VPN on the WAN page; ASUS have enabled this by default (as it's necessary to connect with some Russian ISPs apparently). If you don’t do this, the router will use DHCP on the WAN interface which is an issue

 

8. Reboot the Router via the Admin home page; YouView box powered off


9. Power up the YouView box; check it’s got the static LAN IP address as above


10. Log-on to the Draytek as admin via Ethernet into the single modem WAN port (192.168.2.1)
Under ‘Internet Access’, change the default MPoA setting from ‘disable’ to ‘enable’:

DRAYTEK130_IPTV.png

11. After I made this change, I struggled to log back on to the Draytek modem home page as Admin; I ignored this and moved to the next Step below


12. Reconnect the Ethernet cable from the ASUS router WAN port to the Draytek modem WAN Port


13. BT YouView should now display a picture and sound; the ‘Players’ should work too; my Sky+ box also continued to download Catch-Up TV/Boxsets etc.

 

14. If you have a second YouView box, just plug this into another LAN Port on the ASUS and it will work*

*You will need to pay for ‘multi-room’ for this to work; you will see a message in red on your other ‘primary’ YouView box which states BT have identified a second YouView box

 

I hope that helps. Any questions or feedback please let me know.

 

 

 

0 Ratings
Reply
CirenJules
Beginner
42,113 Views
Message 7 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

DRAYTEK130_IPTV.png

0 Ratings
Reply
kaicho
Beginner
41,627 Views
Message 8 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

Thanks CirenJules for inspiration.

Asus DSL-AC68U.

- Connect ethernet cable between AC68U (any port) and Youview
- Make sure the Internet settings on the YouView box are set to automatic.
- I didn't bother switching off Youview... 
- Do a manual reset pressing reset at the rear of the AC68U device.
- Wait for AC68U to reboot and gain a solid light for DSL
- Connect an ethernet cable between AC68U and your computer
- Router admin should load in a browser window (or try 192.168.1.1)
- Go through Wizard, drop down>UK, drop down>Infinity 2, select Infinity 2 + Youview (although as I discovered this doesn't correctly set up Youview!)
- Enter your wireless settings etc wait for everything to update and load and get back to the admin screen
- Goto LAN>DHCP Server tab. Enable Manual Assignment>Yes. Click on the drop down below and select 'HUMAX' and click + icon to the right. Click [Apply]
- Goto LAN>IPTV tab. Settings None, Leave 'remove VLAN...', RFC3442 & Microsoft, Enable, Enable, 0, [Apply]
- Go to 399 and the Internet Channels should be working

What a waste of a morning setting this up - Good luck and hope this helps improve your day!

0 Ratings
Reply
anthonyUK
Expert
41,600 Views
Message 9 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

@Steveharman wrote:

Sorry to answer my own question, but in case it helps anyone in the future:

 

I had to put my username in the username AND password fields...


For clarity if anyone should find this on a search - You can put anything in the password field but most modems/routers require something e.g. not blank.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
41,584 Views
Message 10 of 12

Re: Trying to get a 3rd Party Router working with BT Infinity....And failing!

Go to solution

@anthonyUK wrote:

@Steveharman wrote:

Sorry to answer my own question, but in case it helps anyone in the future:

 

I had to put my username in the username AND password fields...


For clarity if anyone should find this on a search - You can put anything in the password field but most modems/routers require something e.g. not blank.


As per the above, which is basically the same information given in message 2 by licquorice and you can also use anything you like as the prefix for the username xxxxx@btbroadband.com  

0 Ratings
Reply