cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
volkswind
Beginner
2,372 Views
Message 1 of 6

Unable to have internet connection on my FreeNAS, probably wrong default gateway and DNS

Hi everyone,

I'm using a FreeNAS for my personal storage and downloading. I directly connected it to the BT Hub 6A box with an ethernet cable. My FreeNAS needs this default gateway and Nameserver 1 2 3 for its own network configuration. I put in the Hub's IP into both the defualt gateway and Nameserver 1 but it does not work. I tried to put in the default gateway and DNS information from the Hub's TCP/IP information section under the Advanced Settings/Broadband/Internet page, but the default gateway could not be read by my FreeNAS. What should I do? I have tried both the default value of 192.168.1.254, and a changed value of 192.168.1.1 (where I use the same address for my DNS), which I have changed in the BT Hub settings.

Here are some screenshots:

BT Hub advanced settings/ internetBT Hub advanced settings/ internetFreeNAS Network/Global ConfigurationFreeNAS Network/Global ConfigurationFreeNAS Plugins/AvailableFreeNAS Plugins/Available

0 Ratings
Reply
5 REPLIES 5
Keith_Beddoe
Distinguished Sage
Distinguished Sage
2,370 Views
Message 2 of 6

Re: Unable to have internet connection on my FreeNAS, probably wrong default gateway and DNS

@volkswind 

For a device connected to a BT Home hub.

Default gateway and DNS server should be 192.168.1.254

They are the only setting that will work.

The default gateway shown on the home hub connection page, is BTs gateway router address and you cannot use that.

If your NAS is still having issues, then set its IP address to one outside of the DHCP range, like 192.168.1.50

Why are you accessing the home hub using 192.168.1.1, have you changed the hub configuration?

0 Ratings
Reply
volkswind
Beginner
2,358 Views
Message 3 of 6

Re: Unable to have internet connection on my FreeNAS, probably wrong default gateway and DNS

Hi thanks for the quick response!

I have changed my Hub's setting back to 192.168.1.254. And I have filled this address in for my FreeNAS default gateway and DNS. -> Does not work.

I therefore change my FreeNAS fixed IP from 192.168.1.250 to 192.168.1.50. -> Still does not work.

I really don't know what else I can do.

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
2,350 Views
Message 4 of 6

Re: Unable to have internet connection on my FreeNAS, probably wrong default gateway and DNS

Start again.

Try a factory reset of the home hub.

http://bt.custhelp.com/app/answers/detail/a_id/11386/%7E/how-do-i-reset-my-bt-hub-to-its-factory-set...

Then turn Smart Setup off.

http://bt.custhelp.com/app/answers/detail/a_id/44328/~/switching-smart-setup-on-and-off-on-the-bt-ho...

Leave the home hub settings alone, the issue is with the NAS.

Use these settings on the NAS, do not use DHCP.

IP address 192.168.1.50
Subnet Mask 255.255.255.0  If needed 
Default Gateway 192.168.1.254
DNS Server 192.168.1.254

0 Ratings
Reply
volkswind
Beginner
2,339 Views
Message 5 of 6

Re: Unable to have internet connection on my FreeNAS, probably wrong default gateway and DNS

Hi,

I just have reset my router by pressing the reset button for 20 seconds. And I have disabled the smart setup as instructed as well.

I also have changed my FreeNAS IP config according to your instruction (without the submask code as there is no blank for it.).

However, my FreeNAS still cannot connect to the internet.freenas_ip_config.PNGigb0_setup.PNG

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
2,335 Views
Message 6 of 6

Re: Unable to have internet connection on my FreeNAS, probably wrong default gateway and DNS

Sorry, I cannot offer any other suggestions, as I use a stand alone Zyxel NAS, which works fine with my own third party router.

Perhaps another forum member can help?

0 Ratings
Reply