cancel
Showing results for 
Search instead for 
Did you mean: 
bratman91
Aspiring Expert
277 Views
Message 1 of 13

Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

I have a Home Hub 5 which works fairly well except that wifi in a couple of rooms is poor, so I use powerline adapters to connect a smart TV to the network. However, I have a couple of devices that have no ethernet connection and so can use only wifi. I have a TP-Link W9970 modem/router and would like to connect this to a powerline adapter to give a strong wifi signal in the rooms that the Home Hub can barely reach.

I have followed some fairly basic instructions on the web but without success. I have changed the IP address of the TP-Link router to one OUTSIDE the range specified in the Home Hub DHCP Network Range, disabled the TP-Link DHCP Server and chosen a SSID and Password.

I then connected to TP-Link via a LAN port to a powerline adapater with an ethernet cable. My iPad “sees” the new SSID and, after entering in the password, connects to it but without any internet connection. Oddly, on a couple of occasions, I did get internet connectivity but have not been able to repeat this.  Selecting the SSID of the Home Hub 5 works as normal.

Any suggestions as to what might be the problem?

 

 

0 Ratings
12 REPLIES 12
Distinguished Sage
Distinguished Sage
261 Views
Message 2 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution
Did you set the gateway on the 9970 to 192.168.1.254?
Did you configure the 9970 in wireless router only mode rather than modem/router?
0 Ratings
bratman91
Aspiring Expert
252 Views
Message 3 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

No to both points. Is the “Gateway” what is called the “Default Gateway” with pull-down menu in the WAN settings (there is also a gateway for IPv6 but I assume that this is not needed unless IPv6 is enabled). I will set the router mode as you suggest. Many thanks for your peompt response.

0 Ratings
Distinguished Sage
Distinguished Sage
248 Views
Message 4 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

Yes, default gateway.

0 Ratings
Distinguished Sage
Distinguished Sage
246 Views
Message 5 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

Make sure the 9970 works ok when directly connected to the HUB first of all to eliminate it being a problem with the powerline adaptors.

0 Ratings
Highlighted
bratman91
Aspiring Expert
236 Views
Message 6 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

6E5E6944-8BA5-49D9-B374-69B4B1154C41.png“forwarding” menuThe powerline adaoter works fine. i have changed fhe operating mode on the W9970 to wireless router but I am struggling with chaning the gateway because I can’t find this under WAN settings. However, there is a default gateway in “Forwarding” but I am am not sure if this is what you referred to.

 

0 Ratings
Distinguished Sage
Distinguished Sage
233 Views
Message 7 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

No, but thinking about it, if you are connecting LAN -LAN the Hub will be issuing the default gateway to the end device and the TP Link will just be acting as a switch so you won't need to enter a default gateway in any case.

I would still for test purposes just temporarily connect the TP link directly to the Hub just to completely make sure it isn't the powerline adaptors causing the problem.

Make sure the TP link has a different SSID and uses a different wireless channel to the hub to avoid interference.

0 Ratings
bratman91
Aspiring Expert
224 Views
Message 8 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

The TP-Link has a differenet SSID and channel. I have tried connecting directly to the Home Hib and get the sane result ie. I can connect to the TP-Link SSID but get no internet connection.

0 Ratings
Distinguished Sage
Distinguished Sage
221 Views
Message 9 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

Hmm, not sure where the problem is then. I've just dug out my old TP Link TD-W9980 and that works just fine with everything left as default. Might be worth a factory reset of the 9970, leave it at default settings with  192.168.1.1 address.

0 Ratings
bratman91
Aspiring Expert
213 Views
Message 10 of 13

Re: Using TP-Link W9970 router as Access Point to Home Hub 5

Go to solution

I’ve reset the router and, withour changing anything, tried it. Again, I can connect to it but it doesn’t get any internet access.  I then tried disabling the DHCP server and selecting wireless mode - again, no change. It’s all very odd. Di you leave everything as default on your TP-Link?

0 Ratings