cancel
Showing results for 
Search instead for 
Did you mean: 
FlexiPack
Beginner
383 Views
Message 1 of 5

Wi-fi Speeds poor after 3rd August Firmware Update

I've had BT Infinity since December (with the Smart Hub) and everything has been fine until this week. There was a noticeable change in the speed of connecting to servers/nodes on the internet on Wi-Fi connected devices on the 3rd August. There's also been ocassional Wi-Fi drops as well. I checked the router and there was a firmware update applied that day. I tried the usual re-connecting, rebooting. Didn't help. So I factory reset the router. Still the same. 

The problem lays with the initial loading of items, once a connection is established the data comes at full speed. A speed test sometimes shows this as a dip in the first instance of the test followed by a ramp up to full speed. 

The problem is this affects most things. accessing webpages, in apps such as reddit, streaming music. Everything has a delay before loading; but once it begins to load, it is the speed it should be. If I switch to 4G on my phone there's no delay, it's instant. Which is what my broadband was like before the update. I'm connected using the 5Ghz on my phone but there's no difference on my 2.4Ghz devices. 5Ghz is clear of other router traffic so it's not that either. I've also tried alternative DNS servers to no avail. <edit> I've just retested my phone again after separating the bands. It 'seems' to be much better on 2.4Ghz this time.</edit>

Has anyone noticed this problem? I'm gobbling up my data allowance on my phone because it's just so damn frustrating waiting for the smallest amount of data to come through when it should be instant.


0 Ratings
Reply
4 REPLIES 4
Liam_
Expert
375 Views
Message 2 of 5

Re: Wi-fi Speeds poor after 3rd August Firmware Update

If the delay only happens with wireless the update may be causing a delay in restoring full power to the wireless connection.  Assuming of course the Hub actually has a power saving function.

0 Ratings
Reply
FlexiPack
Beginner
372 Views
Message 3 of 5

Re: Wi-fi Speeds poor after 3rd August Firmware Update

If there is such a power saving funciton, it doesn't appear to be configurable to the end user. Whilst I wouldn't entirely discount such an issue, the fact this happens even after prolonged use of my device (and therefore the wifi being in constant use), makes it unlikely I would have thought?

0 Ratings
Reply
Highlighted
FlexiPack
Beginner
364 Views
Message 4 of 5

Re: Wi-fi Speeds poor after 3rd August Firmware Update

OK, I decided to test splitting the bands again. This time there is a marked difference when using 2.4Ghz. So far (in 10 mins of testing), it's back to what it should be. 

If this is indeed the problem. What could BT have done in the update to fudge the 5GHz?

0 Ratings
Reply
Liam_
Expert
354 Views
Message 5 of 5

Re: Wi-fi Speeds poor after 3rd August Firmware Update

It would seem unlikely to be power saving mode kicking in if a slowdown occurred during constant use.  Don't use a hub and never have that problem here, the router restores full power to the wireless as soon as a device connects.  May just be another hub quirk, some appear to be a little finicky with wireless, going by what I read on here.  So iffy 5GHz may not be the firmware, per se but just the hub.

0 Ratings
Reply