cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Beginner
926 Views
Message 1 of 13

WiFi calling

Hi,

Does anyone know why WiFi calling does not work with BT Fibre (FTTP - Superfast Fibre 4 Plus) - I have a Galaxy S8 phone on EE with WfFi calling enabled.

Thanks

0 Ratings
Reply
12 REPLIES 12
Highlighted
Contributor
905 Views
Message 2 of 13

Re: WiFi calling

Sorry I can't answer your question but I am worried to hear that because we are moving from Virgin to BT for both fibre and phone in 10 days time. And currently wifi calling works very well in our house. We need wifi calling because without it we haven't managed to get a good signal from any of the mobile networks.

I hope someone can answer this important question.

Good luck!

0 Ratings
Reply
Highlighted
Beginner
887 Views
Message 3 of 13

Re: WiFi calling

Good luck!

We have 3 mobiles on EE and 1 on O2 and cannot get a great signal on any - hence why we are trying to use WiFi calling to no avail. BT are sending me an updated router and a disk (whatever that is) but I'm not convinced that will help.

We have FTTP is maybe that is the issue - hopefully I'll find out soon.

0 Ratings
Reply
Highlighted
Beginner
680 Views
Message 4 of 13

Re: WiFi calling

Hi

Same problem here - just spent 45 minutes on the phone with EE thinking this was their issue only to find it is BT who we are stuck with as no-one else provided Fibre here.

My phone keeps dropping calls and it turns out it is because we have a very poor 4G signal and the phones will not pick up wifi calling.

Wish someone had an answer as I feel a long call to BT coming on 😞

0 Ratings
Reply
Highlighted
Moderator
Moderator
666 Views
Message 5 of 13

Re: WiFi calling

@SarahD62, Wifi calling is a feature provided by your mobile provider not the router as it should work on any wifi connection. EE have wifi calling help section on their website that will explain how you can set that up if your phones are compatible.

Highlighted
Beginner
641 Views
Message 6 of 13

Re: WiFi calling

Thanks for the reply. I spent a long time with EE on the phone and they were super helpful. It turns out that 4G can interfere with your phone connecting to wifi calls. In order to rectify you switch the phone to 2G/3G auto connect and problem solved.

Sky mobile do not have wifi calling as a standard feature on their plans so I have yet to speak with them about other phones.

Used to be so easy to activate - now not so much - just glad that I managed to sort it out.

0 Ratings
Reply
Highlighted
Beginner
629 Views
Message 7 of 13

Re: WiFi calling

Hi Sarah,

For clarity are you saying that if I turn off 4G on my phone the WiFi calling will work?

I certainly hope so as my house is virtually a no go area for EE calls - even with the latest BT router and disk!

 

Thanks

0 Ratings
Reply
Beginner
624 Views
Message 8 of 13

Re: WiFi calling

Hi

Yes - it took over 1.5hrs to finally figure it out but it worked and now I have perfect calls loud and clear!

Will be a pain to have to keep swapping back to 4G when I go out but rather that than have calls drop every minute or so in the house!

Depending on what phone you have, go to Settings, Connections, mobile networks, network mode, switch to 2G/3G auto connect and then you should get the wifi calling on your phone (you may have to restart but mine came on instantly)

Hope this help!

0 Ratings
Reply
Highlighted
Beginner
620 Views
Message 9 of 13

Re: WiFi calling

Brilliant - thanks for the quick response. As you say a bit of a faff changing settings but worth it.

As it happens my phone (Galaxy S8) says WiFi calling is enabled but still I can only get a signal in one room and then it cuts out regularly.

Thanks again

0 Ratings
Reply
Highlighted
Beginner
612 Views
Message 10 of 13

Re: WiFi calling

I have an S10 and had wifi calling enabled so couldn't understand what was wrong!

Hope the fix works for you too@

0 Ratings
Reply