cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
morrig47
Contributor
14,387 Views
Message 1 of 26

Wireless Printing with BT Smart Hub 2

Go to solution

I know this issue has been dealt with to some extent, but I have a more specific enquiry.

My setup is an iMac (Mojave), an HP Envy 120 Wireless Printer and a BT Smart Hub 2. When I turn on my printer I log on to my home wireless and all works fine , but if I turn off the printer off then back on again the wireless connection is lost (on the HP printer indicated by a flashing blue light). I then have to log back onto my home wireless on the printer. I have to do this every time; not a great setup. Having undertaken some research on the web my understanding is that the problem might well be to do with the 2.4GHz/5GHz setup. I am also led to believe that wireless printers use the 2.4GHz option which means I have a problem with the new hub as, according to BT's website, I cannot split the SSIDs as "it is designed for Complete WiFi". My solution has been, thus far, to return to a wired connection between my printer and iMac. All well and good, but that means I cannot print directly from my iPad or iPhone.

I would imagine others are in the same boat and I would love to know if they have a solution to this dilemna.

0 Ratings
Reply
25 REPLIES 25
licquorice
Distinguished Sage
Distinguished Sage
14,382 Views
Message 2 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

I have a wireless printer and Smart Hub2, printer works fine. If your printer has only 2.4Ghz then that is all it can connect at, splitting the bands would have no effect even if it were possible.

Have you disabled Smart setup on the hub?

Try giving your printer a static IP address on the printer itself, needs to be outside the DHCP range of the hub, eg 192.168.1.10

Did you manually enter the wireless passkey on the printer or use WPS? If the latter, try the former.

0 Ratings
Reply
morrig47
Contributor
14,373 Views
Message 3 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

Hi licquorce. Many thanks for the response. Just a quick question before I try your suggestions.

I have not tried to disable Smart setup. I have seen a link on how to do this, but are there any implications for any other of my devices if I do this - iMac, iPad, iPhone?

0 Ratings
Reply
imjolly
Distinguished Sage
Distinguished Sage
14,371 Views
Message 4 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

disbale smart setup and problem should be solved  no implications for other devices



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
14,368 Views
Message 5 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

Smart setup is the work of the devil and should never have been implemented on the home hubs, it causes far more problems than anything it is supposed to solve. Disabling it will have no detrimental effect on any your devices.

0 Ratings
Reply
gg30340
Distinguished Sage
Distinguished Sage
14,355 Views
Message 6 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

Turning off "Smart Set Up" will have no negative impact on any of your devices.

It is an out dated piece of software that serves no useful purpose and BT should have binned many years ago

0 Ratings
Reply
morrig47
Contributor
14,350 Views
Message 7 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

Hi both

Not really successful I'm afraid. I disabled smart setup and reset both the router and printer - no change, then I set a static IP Address (the one suggested), but again no change even after resetting the router and printer. N.B. I confirmed the right IP address had been applied by running a test report.

It is very flaky, however, and can suddenly connect to the wireless network after a few minutes right out of the blue i.e. the wireless light suddenly goes solid, but for no apparent reason. I have run a couple of wireless network test results with the following attention results:

1. ”More than one access point/wireless router has been found that matches your wireless network name (SSID). If this is not intended your HP printer may connect to the wrong wireless network. To avoid this change your wireless network name (SSID) to be unique” I guess this is the 2.4GHz/5GHz issue.

2. “Your HP printer is unable to connect to your wireless router. MAC address filtering may be enabled on your wireless router which can prevent your HP printer from connecting to your wireless network during setup” It then suggests checking to see if MAC address is enabled and adding the MAC address of the printer to the list of permitted devices on the router. I assume this is the security aspect of the router. Not sure how I add a MAC and whether you think this might help.

Any further thoughts?

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
14,342 Views
Message 8 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

If the printer is only single band it shouldn't get confused, if it is dual band it may. Although you can't split the bands (easily) on the SH2, you could try disabling the 5Ghz wireless and see if that helps.

morrig47
Contributor
14,337 Views
Message 9 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

Yes I can see that might work. I have, however, looked on my Smart Manager and I have quite a few devices on 5GHz. Might be easier to stick to how things are and have a hard wire setup for the printer to be honest.

Very grateful for all your efforts on my behalf. I will keep a note of this conversation in case I change my mind.

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
14,333 Views
Message 10 of 26

Re: Wireless Printing with BT Smart Hub 2

Go to solution

I think what @licquorice  is suggesting, is to temporarily turn off 5GHz, then connect the printer to 2.4GHz so it remembers and stores the BSSID. Then turn 5GHz back on again, and see if it helps.

0 Ratings
Reply