cancel
Showing results for 
Search instead for 
Did you mean: 
Kaira_95
Beginner
377 Views
Message 1 of 16

Wireless ok but no ethernet - going insane!!

Hi,

 

See title - I just don't know what to do anymore and the more I search for info online the more confused I get.

 

gear: HP laptop with Vista and BT hub 3.0 type A

 

symptoms:

 

- Ethernet connection is local only.

- The network is "non identified" and "public". Tried to change it to "private", it doesn't work.

- In a command window IPCONFIG is "not recognized as an internal or external command, operable program or batch file".

- "PATH" does contain "system32".

- Cables are ok. swapping ports doesn't change anything.

 

If anyone knows how to fix this, please show up... thanks...

0 Ratings
Reply
15 REPLIES 15
Distinguished Sage
371 Views
Message 2 of 16

Re: Wireless ok but no ethernet - going insane!!

has this just happened does it affect only on device or more have you tried a factory reset of the hub
0 Ratings
Reply
Kaira_95
Beginner
347 Views
Message 3 of 16

Re: Wireless ok but no ethernet - going insane!!

Yes I pressed the reset button on the hub but it didn't help. My network card driver is up to date too, or so it says

0 Ratings
Reply
Distinguished Sage
345 Views
Message 4 of 16

Re: Wireless ok but no ethernet - going insane!!

the factory reset normally needs a pin or similar to activate the factory reset feature
0 Ratings
Reply
Distinguished Sage
Distinguished Sage
341 Views
Message 5 of 16

Re: Wireless ok but no ethernet - going insane!!

To do a factory reset of the homehub ypu need to press a pin into the recess button on the rear for about 20 seconds.

0 Ratings
Reply
West
Contributor
336 Views
Message 6 of 16

Re: Wireless ok but no ethernet - going insane!!

I had a similar problem.

 

The recent updates form Microsoft now changes your drivers.

 

My ethernet card could not work with the new driver. Nothing I have done has sorted this. 

 

The answer was a to buy a USB Ethernet adapter. I bought one from StarTech.  USB3.0 TO Gigabit Adapter

 

This has returned me to full speed.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
327 Views
Message 7 of 16

Re: Wireless ok but no ethernet - going insane!!

If an updated driver caused you problems you should be able to roll back the driver to the previous one. If that does not work try uninstalling the network card, restart your computer and let Windows re install it.

0 Ratings
Reply
Kaira_95
Beginner
312 Views
Message 8 of 16

Re: Wireless ok but no ethernet - going insane!!

I did hold the reset button for 20 seconds, in fact doing this I was on the phone with someone from BT...

 

As for the driver issue... I just completely reinstalled Windows back to factory settings, but even before that I could never use the ethernet connection. I also just installed a dual boot Ubuntu, and it can't detect any sort of connection at all. It might be a dumb question but do you need different drivers for the same devices whether you are using Linux or Windows OS?

 

That filter isn't cheap but it could be the solution indeed 🙂

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
306 Views
Message 9 of 16

Re: Wireless ok but no Ethernet - going insane!!

You will need different drivers for you Linux operating system.

 

Can you now use the Internet since you re installed Windows. Have you checked the Device Manger if the network card is installed and working.

 

In Windows go to Start > Control Panel > Device Manager > Network Adaptors. You should see your Ethernet card there.

 

EDIT: Do you have another computer/laptop that you can connect to the homehub to see if it works?

0 Ratings
Reply
Highlighted
Distinguished Sage
Distinguished Sage
302 Views
Message 10 of 16

Re: Wireless ok but no Ethernet - going insane!!

Did you carry out the Windows re install before or after this problem started?

0 Ratings
Reply