cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
warns
Beginner
5,833 Views
Message 1 of 9

Your connection is not private

I would really appreciate if someone could help. I joined BT broadband about 10 days ago and there are many sites giving me the message 'your connection is not private', with an invalid certificate.
I know this so far:

It's not the specific site I'm trying to access. This has happened on many different sites.
It's not browser specific. It happens across chrome and safari
Doesn't seem to happen when I connect through 4g.
Extra info: I'm using a mac. Recently arrived from a different region but I have reset my mac clock to UK time. 
Any advice will be appreciated. 

Screen Shot 2021-10-12 at 12.38.41.pngScreen Shot 2021-10-12 at 12.38.25.png

0 Ratings
Reply
8 REPLIES 8
TimCurtis
Guru
5,796 Views
Message 2 of 9

Re: Your connection is not private

@warns 

Can you post details of any of the sites this happens with including the full address then others here can check on their BT broadband.

Are you using the BT SmartHub or your own modem/router?

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
5,783 Views
Message 3 of 9

Re: Your connection is not private

Sounds like they are HTTP rather than HTTPS sites.

0 Ratings
Reply
warns
Beginner
5,753 Views
Message 4 of 9

Re: Your connection is not private

Thanks. I'm using a bt smarthub
Examples are: www.scotland.org
www.hermanus.co.za
www.surreynational.co.uk
0 Ratings
Reply
TimCurtis
Guru
5,721 Views
Message 5 of 9

Re: Your connection is not private

@warns 

They all work fine for me using a PC with Firefox.

But I don't use a BT SmartHub but an Asus instead, I've no BT Parental controls set & don't use BT's DNS servers.

What you could do is for your network card on the Mac is set it to use googles DNS servers of 8.8.8.8 & 8.8.4.4 and see if that makes a difference.

stevebrass
Recognised Expert
5,713 Views
Message 6 of 9

Re: Your connection is not private

This has come up before.

There is something called BT Web Protect.

It is on by default.

Go to My Bt, Products, Broadband and set web protect to off.

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings icon. If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted solution’
0 Ratings
Reply
5,688 Views
Message 7 of 9

Re: Your connection is not private

 

@stevebrass 

This sounds more of a VPN problem, It's similar the settings warning message you receive using Android on Wi Fi, using "another", (no names!) internet protection software. It's warning that the connection is not private, when on Wi Fi.
I never use my Android on Wi Fi outside of the home, e.g. in a store, where mistakes (or even snooping) can occur. 
Does BT Web protect allow a VPN???? Are there are some VPN settings in Apple PC Operating system? 

0 Ratings
Reply
lifeonmars
Aspiring Expert
5,655 Views
Message 8 of 9

Re: Your connection is not private

Using BT Smart Hub 2 with Chrome and Web Protect setting is on

I can access  1 and 3 of your links without any problem but the middle one  responds with  

Forbidden

You don't have permission to access / on this server.

Examples are: www.scotland.org
www.hermanus.co.za
www.surreynational.co.uk

0 Ratings
Reply
warns
Beginner
5,602 Views
Message 9 of 9

Re: Your connection is not private

thank you. The BT Web protect was not enabled. Seems this issue is with my mac as I had the same problem when using a different wifi. 

0 Ratings
Reply