cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mgrimson
Beginner
2,055 Views
Message 1 of 6

Zero Upload Speeds on Android Devices

In this last week both my partner and I have found our WiFi to be quite slow on our phones (both Android), but useable. However, after receiving messages to say that backups weren't completing overnight, I checked the speed using speedtest.net. Both are getting decent download speeds (Around 40mbps). But we are both getting zero upload speed. 

We've got a few different devices around the house, so I switched them on and tested them all out. The laptop works fine, suggests an upload of around 10mbps. The same of our iPad, works fine with good upload. However, our Amazon Fire tablet running on Android has no upload speed. 

Our friends came over for dinner a couple of nights ago, one has an iPhone the other 2 were Androids. Again, the iPhone worked fine and had good upload speeds but the Androids have nothing. On all devices with 3g/4g sim cards in, we can test the 4G network and it works fine. I also use WiFi at work with my phone and it's OK so I know the issue is with my home network. I'm just not sure where. 

I've checked the router, connections, cabling, nothing has changed. We've only got the one master socket and the router is connected straight to that so there's nothing else to interfere from that side of things. I've checked router setup, and have run the tests on the router home page and it shows as everything being fine. Which I almost expected considering that it seems some devices are working fine. 

I can't work out why, the Android devices are struggling. It's been going on for about a week now and it's doing my head in, so I'm hoping someone out there might have an idea. I've checked a few forums and followed them through to resolution but generally they're all where all devices aren't working. I've not seen any where only some devices don't work.

0 Ratings
Reply
5 REPLIES 5
PaddyB
Moderator
Moderator
2,022 Views
Message 2 of 6

Re: Zero Upload Speeds on Android Devices

Hi @mgrimson,

That is a bit of a strange one. Have you tried splitting out the Wifi SSIDs?

How do I split my BT Hub's SSID (wireless network name)?

That way you can try connecting the Andriod to either the 2.4 or the 5 GHz to see if either on might work better.

Give that a try and let me know how you get on?

Thanks

PaddyB

mgrimson
Beginner
2,013 Views
Message 3 of 6

Re: Zero Upload Speeds on Android Devices

Thanks Paddy, I'll try that after work and feedback.
mgrimson
Beginner
1,997 Views
Message 4 of 6

Re: Zero Upload Speeds on Android Devices

Hi Paddy,
So I've split the bands out into separate networks. I've connected to both individually from multitude devices and it seems the 5ghz band is the problem one.

Connecting on 2.4GHz works fine and we get full down and upload speeds without issue. On 5GHz, back to no upload speed.

I don't suppose you'd have any suggestions as to anything I could do to resolve 5GHz network?

Thanks again
0 Ratings
Reply
Rody
Beginner
1,023 Views
Message 5 of 6

Re: Zero Upload Speeds on Android Devices

Hi,

Has the problem been solved? Please can you tell me how because I have the same problem.

0 Ratings
Reply
gg30340
Distinguished Sage
Distinguished Sage
1,020 Views
Message 6 of 6

Re: Zero Upload Speeds on Android Devices


@Rody wrote:

Hi,

Has the problem been solved? Please can you tell me how because I have the same problem.


You are posting on a three year old thread and the OP has not been back to the forum since the last post.

You would be better to start a new post and give as much details about your problem along with what if anything you have tried to resolve it.

Also include what make and model of device the problem is on and what operating system it is using.

0 Ratings
Reply