cancel
Showing results for 
Search instead for 
Did you mean: 
Mikesin1
Aspiring Contributor
413 Views
Message 11 of 18

Re: dd-wrt access via BTHH5

Go to solution
OK so progress - I can access CETON app from WAN - I believe that BT network I was using to simulate remote access was blocking access - I have been able to test over 3G and from a Sky network and the Ceton app responds - so my remaining problem is
dd-wrt gui access. I have read that BT block port 80 -
0 Ratings
Mikesin1
Aspiring Contributor
410 Views
Message 12 of 18

Re: dd-wrt access via BTHH5

Go to solution
I have tried 80, 8082 and 8086 all without success - how do I decide whether it is a BT problem or dd-wrt ?
Thanks
0 Ratings
Mikesin1
Aspiring Contributor
389 Views
Message 13 of 18

Re: dd-wrt access via BTHH5

Go to solution
It is a BTHH5 problem because I realise that I have tried port forward with 80,8080,8082 8086 and all show as closed when tested with canyouseeme.org
0 Ratings
Mikesin1
Aspiring Contributor
354 Views
Message 14 of 18

Re: dd-wrt access via BTHH5

Go to solution

I have now read in a post somewhere that port forwarding on BTHH5 can only be used when the BTHH5 allocates the IP address. If this is correct the problem is that I am applying a static ip to the dd-wrt router - on BTHH5 devices page the dd-wrt is shown as fixed - how do I change this - I cannot 0.0.0.0 in the ip address field of the dd-wrt router as it complains it is invalid ?  and a lot of the time it shows as "not currently connected" ?   

0 Ratings
smf22
Recognised Expert
348 Views
Message 15 of 18

Re: dd-wrt access via BTHH5

Go to solution

I don't believe that's correct. My Home Hub 5B is configured with a DHCP range of .64 - 199. I have a server with a fixed IP address of .200, and I can port forward on port 80, 8080 and others to that server.

 

With respect to the "connected" status on the HH, that just seems broken or at the very least odd. I've devices here that can communicate locally with other devices on the LAN and can ping the .254 address of the HH, but they still show as "not connected". I've not proven it, but I think the Connected status is somehow related to traffic from the device being forwarded through the HH to the Internet.

 

If you send traffic from the DD-WRT router to a host on the Internet, does it show connected then?

 

Regards

0 Ratings
Highlighted
Mikesin1
Aspiring Contributor
346 Views
Message 16 of 18

Re: dd-wrt access via BTHH5

Go to solution

I'll leave the not "not currently connected" thing to one side for the time being  - I tried streaming from BBC Iplayer to a device connected via the dd-wrt router and it still showed not currently connected...  as regards the port forward to the  dd--wrt router I have an ip address of 192.168.1.1 which is not allocatedby BTHH5 and is obviously outside of the normal default range .. 192.168.1.1 is what is recommended for a second router in the setup guidance for a second router on the network... so perhaps I need to try re-setting up  dd-wrt and see if I can get an ip address within the default range that will let me access the GUI...I'll try tomorrow....

 

Thanks for input 

0 Ratings
smf22
Recognised Expert
338 Views
Message 17 of 18

Re: dd-wrt access via BTHH5

Go to solution

Port forwarding certainly works to i) a host using a static IP 192.168.1.1; ii) listening on port 80; iii) shown an "Not connected" in the HH.

 

So here's a Linux server using 192.168.1.1 for which I've configured port forwarding on the HH:

 

[smf22@cvm1 ~]$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:56:90:6F:19
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::250:56ff:fe90:6f19/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
[snip]

If I run tcpdump on it, and then check it from CanYouSeeMe.org then I see the connection from the host 107.20.89.142 to the server 192.168.1.1, and the server responding.

 

[smf22@cvm1 ~]$ sudo tcpdump -n -i eth0 port 80
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
14:43:20.925698 IP 107.20.89.142.41916 > 192.168.1.1.http: Flags [S], seq 2151657820, win 14600, options [mss 1452,sackOK,TS val 3286738680 ecr 0,nop,wscale 5], length 0
14:43:20.925741 IP 192.168.1.1.http > 107.20.89.142.41916: Flags [S.], seq 832232549, ack 2151657821, win 14480, options [mss 1460,sackOK,TS val 121596026 ecr 3286738680,nop,wscale 6], length 0
14:43:21.014720 IP 107.20.89.142.41916 > 192.168.1.1.http: Flags [.], ack 1, win 457, options [nop,nop,TS val 3286738702 ecr 121596026], length 0
14:43:21.015099 IP 107.20.89.142.41916 > 192.168.1.1.http: Flags [F.], seq 1, ack 1, win 457, options [nop,nop,TS val 3286738703 ecr 121596026], length 0
14:43:21.015479 IP 192.168.1.1.http > 107.20.89.142.41916: Flags [F.], seq 1, ack 2, win 227, options [nop,nop,TS val 121596116 ecr 3286738703], length 0
14:43:21.104361 IP 107.20.89.142.41916 > 192.168.1.1.http: Flags [.], ack 2, win 457, options [nop,nop,TS val 3286738725 ecr 121596116], length 0

To be clear though:

 

1. Before setting up the port forwarding for HTTP I went into Advanced Settings -> Home Network -> Devices and changed the name of my server from Unknown_[some_mac_address] to cvm1

2. In Advanced Settings -> Home Network -> Port Forwarding I selected cvm1 from the Device drop down list

 

Also I tested using a HH5B with software version v0.07.05.0A13-BT. If your HH is a 5A or different software your results may be different

 

Regards

0 Ratings
Mikesin1
Aspiring Contributor
333 Views
Message 18 of 18

Re: dd-wrt access via BTHH5

Go to solution

OK so seem to have it all working now - I think a lot of the problem was that I do not have a good 3G signal and so I tried to test via a BT WIFI with Fon  network that I have access to as part of my BT package and that does not seem to like some of the port forwarding I was trying to achieve - once I was away from home and got a 3g signal I could access my router via port 80 and even via the DDNS service. So now to try wake on WAN and see if that can be made to work - thanks to all for comments and ideas.

 

     

0 Ratings