cancel
Showing results for 
Search instead for 
Did you mean: 
john9411
Contributor
219 Views
Message 31 of 36

Re: ipv6 on archer c7

@SeanD@PinkSquirrel 

Whilst i appreciate your efforts I am unsure as to the outcome.

Some customers use a stand alone modem with separate router, some use a combined modem router - does this affect anything?

There are numerous modem and router manufacturers; some have some models that used to work and now don't; some have models that have never worked and some have models that appear to currently work.

The response that I have had from both TP-Link and ASUS is that some of their models may work but they will give no guarantees. This is a wholly unsatisfactory situation.

The only equipment that it appears is guaranteed to work is the BT Smart Hub.

What we need is a list of equipment (modems, router, combined modem/router) that will currently work and whilst there are technical standards for IPv6which should resolve this issue it is currently not working.  I would suggest that maybe the only way that we are currently going to get such a list is for customers with working set ups to say what they are using.

Would it be possible, @SeanD, to compile such a list and publicise it together with recommended settings?

There is (or was) a list of Openreach compatible modems, we need something similar for IPv6

You would obviously need some means of advertising for the information. Readers of this forum would obviously be aware but as the title relates to a specific router it may not reach everyone with either a problem or a solution.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
206 Views
Message 32 of 36

Re: ipv6 on archer c7

Modems are irrelevant in the context of IP, the IP layer is dealt with by routers not by modems.

0 Ratings
Reply
PinkSquirrel
Contributor
166 Views
Message 33 of 36

Re: ipv6 on archer c7

No good news from BT as a result of the investigation I'm afraid. I've given them as much of the information from this thread and my own experience as I could but as far as they're concerned ipv6 should never have been working for me.  

This was their final response after seeing the information provided by tp-link support:

"Our Specialist Network Engineer has looked into this issue for you to see if we could find any issue without we assign the prefix.

BT allocates an IPv6 delegated prefix to a CPE device which the CPE should use then on its LAN side to allocate out to hosts. This is defined as an IA_PD (Identity Association for Prefix Delegation). This is why in the Router Advertisement (RA) the “M” flag is set to 1.

BT does not allocate IA_NA addresses for the WAN port on the CPE interface, BT expects the link local addresses to be used for this communication. Any request for an IA_NA will always result in a response of no addresses available for IA_NA. This has always been the case from day one of the IPv6 implementation on the platform.

From the capture, we have done of the PPP session setup we can see that the CPE is requesting both an IA_PD and an IA_NA. The allocation of the IA_PD completes and the CPE should have that on its LAN side. This should then enable the CPE to fully work with IPv6.

As we do not handout IA-NA addresses BT replies to the IA_NA request with “NoAddrAvail” (hence the text below). As we know IPv6 works fine with the BT Home Hub and other CPE manufactures.

We will not be able to offer any more support with regards to this issue."

On a brighter note, tp-link support has sent me some beta firmware for my router (Archer VR900). I'll install it in the next few days and report back.

0 Ratings
Reply
john9411
Contributor
150 Views
Message 34 of 36

Re: ipv6 on archer c7

I gave up with TP-Link and bought Asus RT-AC86U which, together with my Vigor 130 modem works perfectly OK with both IPv4 and IPv6. Virtually every time I contacted TP-Link I got mixed responses. First they said it would work, then they said it might and finally they said BT's network was non standard!

It strikes me as odd that telecomms providers and equipment manufacturers manage to mutually agree standards in most areas yet when it comes to IPv6 telecomms providers have different technical specs. This does make it difficult for equipment manufacturers to provide a 'one fits all' solution but it does beg the question as to how some manage to do it!

0 Ratings
Reply
DavidCo
Expert
122 Views
Message 35 of 36

Re: ipv6 on archer c7

 
 
 

 

I have a VR900 (V2) and the old beta firmware.

I would be keen to hear about the new beta?

Just for clarity, how many users on this thread have BT IPv6 DNS active?

 

0 Ratings
Reply
PinkSquirrel
Contributor
37 Views
Message 36 of 36

Re: ipv6 on archer c7

It's been a while since my last update but after I sent tp-link support the info supplied from BT's investigation they pulled the beta firmware they'd sent me and said they'd produce something new. 

Well I've now installed the new beta firmware on my VR900 v2 - and ipv6 is working!

I still have no idea why ipv6 was working previously and then stopped - when BT are certain they haven't changed anything - but as least this is a solution to the problem. 

If anyone else has a similar problem it may be worth logging a support call too.

I've seen some comments on these forums suggesting that tp-link support isn't that good but I've found them easy to deal with and they stuck with my problem until it was fixed.