cancel
Showing results for 
Search instead for 
Did you mean: 
GL1948
Aspiring Contributor
5,523 Views
Message 1 of 12

BT8500 Base Unit

recently bought a BT8500 quad system direct from BT. Followed all of the set up instructions, set the base unit up and the 3 other units. Base unit had green light (power on) and red light (charging) on. Before I could finish the 3 other units, noticed that each said error, lost connection to base. Checked base which was quite warm, no green or red lights. Returned it to BT for refund. Ordered same system from Amazon - things went fine for 3 or 4 days, then same problem with the base unit - no power and each of the 3 other units had errors lost connection to base. Item returned to Amazon and awaiting 3rd system in hope that this one works. Have tried them in different power sockets (there's nothing wrong with power to the house or any other equipment). Any thoughts please before the 3rd system arrives? - have I just been unlucky?
0 Ratings
Reply
11 REPLIES 11
Moderator
Moderator
5,496 Views
Message 2 of 12

Re: BT8500 Base Unit

Hi GL1948,

 

That's not good at all have you spoken to the BT8500 Helpdesk? 0800 145 6789 They should be able to office advice on this.

 

Thanks

Neil

0 Ratings
Reply
GL1948
Aspiring Contributor
5,494 Views
Message 3 of 12

Re: BT8500 Base Unit

Thanks Mark

Yes spoke with the BT Helpdesk the first time and they advised to disconnect mains power and line, leave for 30 mins and try again. I did this but without any success. Didn't call them the 2nd time. I now have the 3rd system with the base unit plugged into mains (since about 1400 today) and handset in its cradle charging (line not yet connected). Green light and red light both on permanently. Tomorrow, I plan to set up the main handset before then plugging in the other 3 units and handsets to allow them to charge. I'm following the instructions by the letter (as I did previously)
Never had this problem with any of the previous telephone systems I've had. Just a little bewildered at my experiences with the BT8500 to date and envious of the many positive reports about it from other owners.
0 Ratings
Reply
GL1948
Aspiring Contributor
5,476 Views
Message 4 of 12

Re: BT8500 Base Unit

Just an update.

Firstly apologies to Neil who I called Mark in my last reply! Senior moment!

Touching wood and tempting fate probably, but system has been up and running fine for the past 4 days (already caught and blocked some unwanted calls). Suspect just unlucky with the previous 2 systems which I assume had faulty base units, strange in such a high quality system. If it fails again (hopefully not) will re-post and look elsewhere
0 Ratings
Reply
Moderator
Moderator
5,471 Views
Message 5 of 12

Re: BT8500 Base Unit

Hi GL1948,

 

No worries :)I'm glad to see it's working for you now.

 

Neil

0 Ratings
Reply
Daryll
Newbie
5,396 Views
Message 6 of 12

Re: BT8500 Base Unit

I'm afraid this seems to be a recurring problem..... I too purchased a 8500 quad pack 2 months ago (from Amazon), and today all the phones have a "lost connection to base" (or something similar) message.

I have tried disconnecting from the power for 10 mins with no luck, and then for an hour, again nothing.

It seems there is power getting to the base station, as the phone bleeps and says its charging when I put the handset back in the cradle, but no lights are showing and none of the answer machine buttons work.

A failure in someone's QC process..??
0 Ratings
Reply
GL1948
Aspiring Contributor
5,390 Views
Message 7 of 12

Re: BT8500 Base Unit

Sorry to hear this Daryll, hope not a sign of things to come! Touching wood, our system still working fine and blocked scores of unwanted calls.

Doesn't create any confidence in the product, be interesting to hear BT's views.

Hope you get it resolved or indeed replaced. Amazon usually good with these sort of things.

Good luck
0 Ratings
Reply
Daryll
Newbie
5,384 Views
Message 8 of 12

Re: BT8500 Base Unit

Thanks GL1948, Yes, I'm considering sending back to Amazon, or the actual supplier, but i know they'll want the whole package of 4 phones, chargers and base station back, which seems a lot of hassle when we know its only the base station.

What maybe a simpler option, is to buy just the base station from another supplier... if that goes wrong again all i need to send back is the base station...
0 Ratings
Reply
GL1948
Aspiring Contributor
5,382 Views
Message 9 of 12

Re: BT8500 Base Unit

Like the lateral thinking, just a pity have to resort to this; you shouldn't really be out of pocket for a faulty product. Could always try phoning Amazon and see if they would be prepared to just swop the base unit, although they may indeed insist on you sending the whole set up back as they will need to deal with the supplier.

It does seem a bit hit or miss with these base units.

Good luck
0 Ratings
Reply
GB-UK
Newbie
5,356 Views
Message 10 of 12

Re: BT8500 Base Unit

BT8500 - a phone I love (feature set) and absolutely hate (shocking reliability). I feel the pain of fellow owners who have experienced reliability problems with this BT product.

 

In April 2015, I bought a BT8500 quad pack from Amazon (sold and supplied via LiGo). It lasted 4 days before the base unit died. Tried the standard support suggestions to no success. I spoke to BT support, who didn't bat an eyelid, and they simply gave me a fault code then instructed me to return it to Amazon/LiGo.

 

In May 2015, I bought a BT8500 trio pack from Amazon (this time sold and supplied direct from Amazon). I've had it running for over a week and suddenly all phones have lost connection to the base and won't reconnect. I've tried all known support suggestions (check cables, power down for a time, re-seat batteries, disconnect and re-attach cables etc) and nothing has fixed the issue.

 

My home environment (power, sockets, surge protected adapters) works perfectly fine so no issues there and my previous cordless phone still works a treat. So, I'm left with the view that the BT8500 product set has stunning reliability problems or that Amazon and it's co-sellers have received badly manufactured batches.

 

Oh well, I have go kick off another returns process with Amazon. While I'm contemplating a "3rd try" with the BT8500 I'm not sure I could go through another failure.

0 Ratings
Reply