cancel
Showing results for 
Search instead for 
Did you mean: 
SheepRustler
Beginner
187 Views
Message 1 of 6

Bt8500 odd problem

So my bt8500 has suddenly stopped working. Here’s the symptoms:

If I pick the receiver up I get a dial tone, but if i try to dial out it it never connects, there’s just static on the line. If I hang up I don’t then return to a dial tone and the only way to restore the dial tone is to unplug and replug the phone line. If try to dial in whilst in this state, the line is engaged. Incoming calls never cause the phone to ring.

I’ve done a reset of the handsets and base unit.

Plugging an old corded phone in the line works ok and I can make outgoing and receive calls (but is very noisy).

Everything else on the base unit is ok, answer phone, charging etc. 

Anyone any thoughts on if it’s a line fault or if the base unit has failed?

Thanks

0 Ratings
5 REPLIES 5
Distinguished Sage
Distinguished Sage
183 Views
Message 2 of 6

Re: Bt8500 odd problem

Most likely a line fault, but check in the test socket first, to avoid a possible charge if its your internal wiring.

test socket.jpg

0 Ratings
Moderator
Moderator
181 Views
Message 3 of 6

Re: Bt8500 odd problem

Hi @SheepRustler and welcome.

 

I'm sorry your having problems with the line. You've mentioned noise on the line so can you try the advice posted by @Keith_Beddoe and let us know how you get on?

 

Cheers

 

David

Community ModeratorDaveM
Did you get the help you needed?
Help others by clicking on ‘Mark as accepted solution’
Show your appreciation!
Click on the star next to a reply to say thanks
Help guide to using the community? Click below
Kudos”
Please avoid contacting us (moderators) via private message, for account/fault issues, unless invited to do so. The community will be able to help answer your question so we encourage you to create a new thread if you can’t find the answer from existing discussions. The moderators will be around to lend a hand should the community not have the answers. Thank You
0 Ratings
SheepRustler
Beginner
176 Views
Message 4 of 6

Re: Bt8500 odd problem

Yes, thanks. I should have said I’d tried plugging into the master test socket, it’s the same.

0 Ratings
Distinguished Sage
Distinguished Sage
165 Views
Message 5 of 6

Re: Bt8500 odd problem


@SheepRustler wrote:

Yes, thanks. I should have said I’d tried plugging into the master test socket, it’s the same.


Then report it as a noisy phone line. Call 0800 800 151.

0 Ratings
SheepRustler
Beginner
157 Views
Message 6 of 6

Re: Bt8500 odd problem

Ok thanks. It just seemed odd that a corded phone works ok but not the bt8500. We are used to a noisy line as we live in a remote part of Cumbria but I was just a bit wary of getting hit with a bill if it was the base unit. I’ll report it. Thanks
0 Ratings