cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
grandles
Beginner
352 Views
Message 1 of 18

Re: Caller display not working, going round in circles

I recently changed over from standard broadband to FTTH and have now lost my caller display feature also.  Perhaps this could be the same issue.

0 Ratings
Reply
17 REPLIES 17
Keith_Beddoe
Distinguished Sage
Distinguished Sage
344 Views
Message 2 of 18

Re: Caller display not working, going round in circles

@grandles 

Are you now on BT Digital Voice, if so, I think you have to enable it via MyBT?

https://www.bt.com/help/landline/digital-voice--how-do-i-use-my-calling-features-#:~:text=Managing%2....

0 Ratings
Reply
grandles
Beginner
334 Views
Message 3 of 18

Re: Caller display not working, going round in circles

Hi Keith,
Thanks for the reply. I'm honestly not sure if I am on BT Digital Voice. I was on BT Infinity Broadband, with fibre to the cabinet, then over copper to my home. My main phone box had the house phone connected and then a DSL connection off to the home hub.

Now, I'm on BT Halo, with a fibre directly to the home and into a fibre tray. The home phone is still connected to the existing main phone box. The phone line itself works, incoming and outgoing calls are working. Just now when an incoming call comes in, the display on any of the house phones says 'No Number' rather than displaying the number.

Does the BT Digital Voice service connect this way, or would that have needed the home phones connect to the 'Phone' port in the fibre tray?
0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
330 Views
Message 4 of 18

Re: Caller display not working, going round in circles

Then your phone line is the same.

When you upgraded, caller display would not automatically be added to your account, so you will need to add it to your line by logging into MyBT and using the "manage phone features" section.

There will be an option there to order your free caller display feature.

 

0 Ratings
Reply
grandles
Beginner
328 Views
Message 5 of 18

Re: Caller display not working, going round in circles

I've just had a quick read through the 'Digital Voice' section via MyBT. I don't have that service, so I'm assuming this issues is not the BT Digital Voice issue and is with the standard phone line.
0 Ratings
Reply
grandles
Beginner
326 Views
Message 6 of 18

Re: Caller display not working, going round in circles

I done that last night to re-add the service and received an automated message after a short time to advise that it was now active, but when I make a test call from my mobile to the home number, it still displays 'No Number' on all device displays in the house.

I'll try again now though, just to be sure.
0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
322 Views
Message 7 of 18

Re: Caller display not working, going round in circles

Please check to see if Caller Display is switched on by entering the
code * # 234 #. If it's active you'll get the message Caller identity will
be displayed.

0 Ratings
Reply
grandles
Beginner
319 Views
Message 8 of 18

Re: Caller display not working, going round in circles

When I try to re-add the service via MyBT, I get a message "Please either add or remove calling features to proceed - items that are selected are already active on the account"
----------
I entered the code *#234# on my landline and get the message "Sorry, the service requested is not available. Thank you for calling. Please hang up."
0 Ratings
Reply
grandles
Beginner
309 Views
Message 9 of 18

Re: Caller display not working, going round in circles

This is what I get when I try to add the service to my account...Which indicates to me that the service is already there.

https://drive.google.com/file/d/1_xC_gOnJVSRKVs7dEv_ng3KZHWZ4LC8s/view?usp=sharing
0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
305 Views
Message 10 of 18

Re: Caller display not working, going round in circles


@grandles wrote:
When I try to re-add the service via MyBT, I get a message "Please either add or remove calling features to proceed - items that are selected are already active on the account"
----------
I entered the code *#234# on my landline and get the message "Sorry, the service requested is not available. Thank you for calling. Please hang up."

Then its not active on your account as the instruction has not been send to the exchange equipment. That can sometimes happen.

What you need to do is to remove the feature, and progress the order. Then wait 48 hours and add it again. That should resent the command to the exchange.

0 Ratings
Reply