Showing results for 
Search instead for 
Do you mean 
Reply
Aspiring Contributor
Posts: 11
Registered: ‎11-02-2016
0 Ratings

Re: Netflix - Just stopped working!

Admittedly that thread concerns access on Smart telly a but might be the same issue
Beginner
Posts: 3
Registered: ‎21-02-2013
0 Ratings

Re: Netflix - Just stopped working!

[ Edited ]

Exactly the same issue as other users .. Cant sign into Netflix on either Youview Box or Samsung Smart TV but works fine on IPAD ??  Have subscription to Netflix via BT so hope this gets sorted soon as the Netflix part of my subscription is a waste of money at the moment 😞. From reading the other threads on this issue it seems to a problem for users with Home Hub 3B which includes me.

Distinguished Guru
Posts: 4,679
Registered: ‎28-02-2010
0 Ratings

Re: Netflix - Just stopped working!

netflix issue raised on the broadband thread could be an issue with the homehub type. others have changed from a 3 to either a 5 or to a 3rd party router.
(If I have helped you in any way to say "Thank You" please click on the star next to the message. Thank You)
If I have solved your Issue please click the "Mark as accepted solution" button.
Newbie
Posts: 2
Registered: ‎01-02-2016
0 Ratings

Re: Netflix - Just stopped working!

After following up my earlier post with the mods as suggested I was sent a replacement HH3 and after swapping it all seems fine.  Can access Netflix fine now on all devices on first attempt including TV which refused to connect at all.

Highlighted
Newbie
Posts: 1
Registered: ‎13-01-2018
0 Ratings

Re: Netflix - Just stopped working!

I fixed the issue on our humax box. It is a DNS issue whereby the routers DNS does pick up Netflix servers but doesn't allow the app to work properly somehow.

Solutions:
change broadband or network settings on device to manual.
Look for primary DNS
copy it exactly into the secondary DNS box
You may need to hit the right arrow to skip to the next dot sometimes
Set primary DNS to 4.2.2.2
Ok. Save settings.
Power off and power on to confirm new configuration
try Netflix

I'm not a networking master so sorry if my explanation is out. But that worked for me.

If it fails, to revert back simply go back to network setting, change to manual, copy secondary DNS into primary, set secondary to 4.2.2.2 and save, power off and power on (this is all important!!!) And you'll be back to where you were before.