cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
379 Views
Message 1 of 1

BT Pro Box - Arrives + Pink Welcome to BT screen then nothing!

Hi Everyone!

 

Renewed my BT contract and Upgraded to the new BT Pro Box with 4k Sport and received new BT Hub Router for Fibre.

 

Plugged in new BT Pro Box, New Hub , Wired Pro Box to Hub , Swapped Arial in and got the Pink BT screen - 5 seconds later black screen and nothing. Repeated turn off/on and Factory reset never got past the pink screen - black no signal received screen . Any time box is on all i get is the purple circle - **NEVER** any lights in the 3 LEDS on the box

Setup is all good - swapped back in my OLD 4K BT Youview box and everything works as expected so in my mind that means Internet, Hub, Aerial, HDMI to TV all good. Something is clearly up with this new Box

Phone BT and the engineer tries to convince me it might be something to do with the Hub or router and is asking for factory resets again. I decided to upgrade due to previous constant Freezing and failure to turn on with the old 4k Box

So, we have

1 A  pink BT logo screen and then box just goes off, never progreses

2. New Hub is working and 20+ devices wired/wireless all connected

3. Old box when swapped in with same Aerial, Cable to Hub, HDMI to TV works as expected

I can only conclude the Box is damaged in transit or faulty from stock -Anyone experienced similar? Quite frankly fed up with these poor TV boxes from BT.

 

 

 

 

0 Ratings
Reply