Showing results for 
Search instead for 
Did you mean: 
Aspiring Contributor
Message 1 of 5

BT TV internet channels not working

Hi all,


I have a Netgear D7000 Nighthawk AC1900 - the router used to work perfectly fine with the BT TV, but now I find I'm having to restart my router before I am able to watch the internet channels.


This all started when I upgraded to the HD pack to get all the HD channels. I don't use the BT TV very much, mainly every Saturday. I'll switch the BT TV on, go to an internet channel like Discovery and it'll be a blank screen. If I restart the router, it'll then let me watch the channel.


Any suggestions? I was thinking about port forwarding, but I'm not sure which ports are needed by the box.


0 Ratings
Aspiring Expert
Message 2 of 5

Re: BT TV internet channels not working

Have you checked the multicast configuration on the router? This is what BT use to deliver the IPTV channels and if not correctly configured the channels won't work.
0 Ratings
Recognised Expert
Message 3 of 5

Re: BT TV internet channels not working

Look at the post "Using 3rd party Routers...." which is on the first page of this Forum, it might give you some help.
0 Ratings
BT TV Expert
BT TV Expert
Message 4 of 5

Re: BT TV internet channels not working

Hi @jackh1


If still having issues after trying the things suggested by other contributers. Please drop me a PM with your telephone number. And I will have a look into the issue for you.

Thank you.

Community ModeratorGemma
Did you get the help you needed?
Help others by clicking on ‘Mark as accepted solution’
Show your appreciation!
Click on the star next to a reply to say thanks
Help guide to using the community? Click below
I am a BT Employee and an expert on TV queries. I am here volunteering my own time to give advice, and help where I can with BTTV queries. Go here for more info.
0 Ratings
Aspiring Contributor
Message 5 of 5

Re: BT TV internet channels not working

The annoying this with this is its an intermittent fault. I've just tried the BT TV now and its working fine, but it'll most likely stop working again.

I have unchecked the Disable IGMP Proxying, though I doubt this will be a fix as it's worked with it ticked before.


Will keep you updated.

0 Ratings