cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
22,611 Views
Message 1 of 7

Extra IPTV channels working on Mikrotik 750G router - a short technical how-to.

I've seen a lot of posts about common consumer routers like Asus, Netgear but nothing for Mikrotik so I will pass on my discoveries, it might help people with other more unusual routers as well... I've assumed use of WinBox for configuration, it's all possible on the terminal too.

 

I'm using a 750G, this should hopefully work for at least any device running RouterOS 6.x, I have the Openreach Huawei Infinity modem connected with cat5e to eth1 on the Mikrotik and the internet connection is then dialled with PPPoE over eth1.

 

Give your VouView box a static IP or reserve its DHCP address. I've isolated my YouView box, directly cabled it to the router's eth5 (I've removed switch group config) and put it on a different subnet etc, I don't think this step is necessary though so I won't go into detail. I felt better about my LAN security doing it though.

 

Go to the Mikrotik download page and get the all packages zip for your router, extract and install the multicast npk by dropping it into Files through Winbox and then restart the router. You should now find "IGMP Proxy" in the Routing section of Winbox, open that.

 

The IGMP traffic won't appear to come through the PPPoE interface instead it will be on the ethernet interface that is physically connected to the Openreach modem, in my case eth1. You'll need to assign an IP adress to this interface if you haven't already, making it anything in a private range but outside your LAN ranges, e.g. 10.20.30.1/24, only because RouterOS won't make use of the interface without an address assigned.

 

Add an interface in the IGMP-Proxy, select the interface the modem is on from the drop-down, in additional subnets enter 0.0.0.0/0 and finally tick the upstream option and save it. Then add another interface and select whatever interface your YouView is reachable on from the drop down, don't change any other settings and save it.

 

Enable Quick Leave in the settings of IGMP-Proxy, this allows IGMP devices to send a leave notice and stop a stream instantly so you don't get flooded with UDP traffic until group membership times out.

 

IGMP-Proxy allows devices on the LAN to send an IGMP membership request, it will be picked up by the router and forwarded on the configured upstream interface, IGMP messages to the group address will then be forwarded back to the device by the router according to the entries auto-generated in the MFC tab.

 

Your router needs to actually accept the IGMP traffic on the selected interfaces, it will be seen as addressed to the router so add a rule to the input chain in IP > Firewall > Filter Rules, enter igmp as the protocol, action as accept.

 

Then add a rule to both the input and forward chains, dst address is the multicast group that will receive the IPTV streams, protocol is UDP, in-interface is the upstream in IGMP-Proxy, action is accept.

 

You can discover the address of the multicast group from the MFC tab in IGMP-Proxy (an entry should appear if you attempt to tune an IPTV channel, 900 is good to test) or by adding a rule early in your forward or input chains with dst-address as 224.0.0.1/4, protocol UDP, in-interface as the upstream in IGMP-Proxy and action as add-dst-to-list with whatever list name you choose. I found all channels I tried to be in 234.81.130.0/24, I don't know if this differs or is the same for every BT customer.

 

Now go to your YouView box and tune to 900, if you've got the multicast group right it should work, picture should appear almost instantly and you should be able to see the traffic moving through the router.

 

If you've got issues or are just interested in what happens try adding logging rules in System > Logging to send IGMP-Proxy debug to memory.

 

Hope this is of some use to somebody somewhere!

6 REPLIES 6
keithy999
Beginner
22,509 Views
Message 2 of 7

Re: Extra IPTV channels working on Mikrotik 750G router - a short technical how-to.

Very useful - thank you

0 Ratings
Reply
kjohnphillip
Aspiring Contributor
22,203 Views
Message 3 of 7

Re: Extra IPTV channels working on Mikrotik 750G router - a short technical how-to.

Thank you so much. I've been trying to get this to work for ages with a Mikrotik RB2011UAS-2HnD. The missing link for me was "The IGMP traffic won't appear to come through the PPPoE interface instead it will be on the ethernet interface".

0 Ratings
Reply
chulann
Beginner
13,153 Views
Message 4 of 7

Re: Extra IPTV channels working on Mikrotik 750G router - a short technical how-to.

 

Many thanks for this - really helpful.

 

The setup I have is similar (Openreach modem on ether1) but the difference is that the YouView box is connected via a separate switch so there is 5 devices connected on the port into my MikroTik (The TV, DVD player, Fire TV, amp).

 

However, I didn't need to isolate the port and I haven't set a static IP for the YouView address.

 

Also, I didn't need to add firewall rules - as soon as I setup a upstream IGMP proxy on ether1-gateway with alternative subnets set to 0.0.0.0/0 and Quick Leave enabled, it started to work. I do have downstream rules under IGMP proxy for interface of "all" and "bridge-local" - all the traffic seems to be going over bridge-local.

 

 

0 Ratings
Reply
psykix
Contributor
11,179 Views
Message 5 of 7

Re: Extra IPTV channels working on Mikrotik 750G router - a short technical how-to.

I know this is an old thread, but I am currently trying to set up the same on my Mikrotik RB2011.

 

I have it working, but I'm struggling to get the IGMP flooding under control.

 

I know the Mikrotik doesn't have IGMP snooping so is there something else I should be doing?

 

I have a Cisco GS200-08 switch which supports IGMP snooping but not sure where I should be placing the switch or how best to configure it.

 

The Mikrotik is in the garage where my WAN connection is, and there are 2 dumb switches (one in the living room and one in the kitchen) connecting the Youview box and Xbox One's and so on.

 

The Cisco switch is currently hanging off the Mikrotik Lan port.


Hoping for some pointers - I'm very new to Mikrotik having only received it today!

 

0 Ratings
Reply
Heathy65
Beginner
9,463 Views
Message 6 of 7

Re: Extra IPTV channels working on Mikrotik 750G router - a short technical how-to.

BTTV working via a BT Openreach modem along with my Mikrotik router 🙂

 

Thanks!

0 Ratings
Reply
1,290 Views
Message 7 of 7

Re: Extra IPTV channels working on Mikrotik 750G router - a short technical how-to.

Bit of a long shot. I have this working but after watching TV for 4 mins 30 seconds, the stream fails. Changing channel recovers things, but only for another 4 mins 30 seconds! Running RouterOS v6.44. Not sure what is causing it. 

Hmm actually googling around I think it might be dropping out after 256 seconds

Tags (1)
0 Ratings
Reply