cancel
Showing results for 
Search instead for 
Did you mean: 
rdn
Beginner
3,065 Views
Message 1 of 7

HDMI-CEC issues?

Hello, just joined BT and received a (not G4) Youview box.  I cannot seem to make the HDMI connection work.  When the box first boots, I see the HUMAX logo, and version A7.76.  After ~15s, the picture disappears, and my TV indicates no signal received on the HDMI.

 

If I instead use the SCART or 3-component connection, I see the HUMAX on boot, and then after those ~15s I get the Youview logo with those 4 dots.  Unfortunately, no high-def on these connections.

 

I've talked to BT support, who sent me a new box, but it does exactly the same thing.  I have many HDMI cables, none work, including ones which work with other components. 

 

My TV is not the newest LCD (Sharp Aquos), but I just came from Virgin, whose Tivo box happily output 1080i to this TV.

 

Some googling makes me think the HDMI-CEC negotiation may be failing.  Is there any secret to forcing the Youview box to "turn the TV on"?

 

The non-BT branded HUMAX boxes have had a number of software updates that specifically address the HDMI-CEC negotiation not working correctly with some TVs.  Any hope for a BT version?  (Can I try flashing the HUMAX firmware on the BT box???)

 

THanks for the help,

Rex

 

0 Ratings
Reply
6 REPLIES 6
rdn
Beginner
2,999 Views
Message 2 of 7

Re: HDMI-CEC issues?

For what it's worth, after going through useless and rude tech support in India twice, an engineer visit was scheduled. The engineer was great (not a BT employee but subcontracted).


We tried an old Vision box:  worked perfectly over HDMI

We tried another Youview box:  same issue, no HDMI

We tried the "new" Youview box (G4):  worked perfectly over HDMI

 

So this obviously was an issue with the borked Humax implementation of HDMI negotiation on that generation of box.

 

Hope this helps someone else with the same issues!

 

0 Ratings
Reply
Distinguished Guru
Distinguished Guru
2,994 Views
Message 3 of 7

Re: HDMI-CEC issues?

The G4 is probably at the same 17.3.0 software level as the Humax retail boxes.

 

The original BT Youview box is probably at the release 15.14 or 15.11  software level. That would be lacking some of the fixes/changes that have been delivered in the release 16.xx and 17.xx retail releases.

 

As you found out there have been several compatiblity issues with certain brands.types of TV reported on the youview forums ...some appear to have been resolved by software updates either to Youview or the Tv. You will probanly find the explanation as to why the problem exists and what has been addresed in what release  somewhere on the youview community forum but that forum's search facility is so poor that finding useful posts on it is very difficult.

0 Ratings
Reply
Highlighted
mentonman
Contributor
2,948 Views
Message 4 of 7

Re: HDMI-CEC issues?

I to have similar problems since the upgrade to 15.14 software.My Sony tv has worked fine up until then but now when the You View box is switched into the standby mode the tv stays on the link to the box.

It is ok on switching on the You View  when the hdmi/cec comes into play.Obviously this has been caused by the software upgrade.

This was a previous problem on earlier versions of the software which were eventually cleared by updates.

0 Ratings
Reply
2,850 Views
Message 5 of 7

Re: HDMI-CEC issues?

I have also been having issues with my Sony TV and Receiver complaining, getting the message "TV speakers active due to Audio System Communication failure".  Thought I had a bad cable but have since proved otherwise.  The problem seems consistent with recent Youview software up(down!)-grade.   I think the YouView software is hanging onto the CEC control channel from what have gathered from various other posts.  Most annoying considering it has always worked fine for me since i got it 6 months ago.

0 Ratings
Reply
Travelstar
Contributor
2,799 Views
Message 6 of 7

Re: HDMI-CEC issues?

I've also noticed a few issues this week. I've managed to get around the problem by downloading the latest firmware update for my amp which seems to have restored comms with the G4 box I have been given. If I were in your shoes, I would check that your amp is on the latest firmware revision.

0 Ratings
Reply
mrbutt89
Aspiring Contributor
1,097 Views
Message 7 of 7

Re: HDMI-CEC issues?

Just in case someone stumbles across this elderly thread in their search for a solution...

 

I was experiencing a problem with my TV switching back to its internal speakers, rather than sending the sound to my AV receiver, due to a "communication error".

It turned out that the culprit was my Humax PVR. Even though the HDMI-CEC option was switched off, it was still sending out spurious control signals via the HDMI lead and upsetting the other components.

It was suggested to me that I should try a **edited by mod** It cost less than a tenner and resolved the problem immediately.

0 Ratings
Reply