cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Lexx920
Beginner
295 Views
Message 1 of 2

Youview Extra Channels / BTPlayer Missing. Please Help...

Go to solution

Hi All,

 

Having a frustrating problem and BT seem unable/unwilling to help. Switched on my YouView box a week ago to watch BT Sport and found that all of my Extra channels had disappeared. BTPlayer was also missing. Everything was working fine, and nothing in my hardware setup had been changed, and as others have experienced I too seem to be getting fobbed off by BT with "Oh, we'll give you a call back from our technical team within 24 hours" - not once but twice so far!

 

I do have an unusual setup that was working fine for over 2 months; Openreach Modem connected to my Asus RT-AC3200 Router (running Asus WRT-Merlin 380.65_4 firmware), which in turn is  connected via ethernet to my YouView box. The YV box has been reset, updated, reset via maintenance mode, turned upside down and talked to nicely but to no avail.

 

Symptoms: None of the Extra channels work (i.e. AMC - 381, BT Sport 1HD - 430). All I get is a "No Channel" message. The "Sport" section in the guide has disappeared entirely, as has the "BTPlayer" option. Weird. There are no other error messages. I have no other BT Infinity issues (i.e. I can use internet from all of the other devices in my house without error).

 

What I have tried: All the usual stuff from the BT "Support" Call centre (i.e. factory reset of YV box, reboot router, maintenance mode YV reset, switch box off/on, plug in HH6 and test, update HH6 etc etc etc. Have also tried;

*-Disable Router firewall - no joy

*-Switch all equipment off and restart in order (Openreach modem, Router, YV box) - no joy

*-Connect only the YV box to router - no joy

*-Plugged in the old HH6 router and connect via ethernet to YV box and test - no joy

 

My Router IPTV setup:

*-ISP Profile - None

*-IPTV STB Port - None

*-Use DHCP routes - Microsoft

*-Enable IGMP Multicast routing - Enabled

*-Enable efficient Multicast Forwarding - Enabled

*-UDP Proxy - 0

 

Sorry for the long post but this was working flawlessly (after spending many hours researching how to get it setup with my own router) and I watched many  footy games on BT Sport without issue, so I am perplexed why this has happened without any changes at my end. Appreciate this is not the usual setup, but if anyone has any ideas - I would gladly welcome the advice, while I wait for my phantom callback from BT. Lastly - I get the same problem when I use the original BT HH6 router which suggests to me a problem at BT's end somewhere....

 

Thanks!

Tags (2)
0 Ratings
1 REPLY 1
Lexx920
Beginner
282 Views
Message 2 of 2

Re: Youview Extra Channels / BTPlayer Missing. Please Help...

Go to solution

Ok...so I've fixed it! Thought I would be a good community member and share my findings for anyone else in a similar situation.

 

The fix: disabled IGMP Snooping (aka: Enable Efficient Multicast Forwarding) and applied change. Re-Enabled IGMP Snooping and tested - all now ok.

 

How I got to this: I hadn't tried accessing BT Sport via the website. When I did so I received a "VC011" error message (which I understand to be a playback over the internet issue). This pointed me back to my router. Deployed Wireshark and started inspecting some of the packets and noticed some IGMP activity going on. Decided to play with the only IGMP settings on my router and one of the 2 settings worked.

 

Other Actions: Once the setting was changed and applied, testing on the BT Sport website was fine. However I needed to reconnect my YouView box to my router by forcing a connection (i.e. attempting to change broadband settings, and selecting "Automatic" to reconnect). I then had to run a software update to get the channels back and BTPlayer, after which the YV box reboots itself and all is well.

 

Means I can keep using my own router, and now can watch BT Sport and the kids gorge on Blaze on BTPlayer...

 

Hope this helps.