Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 10


Hi. We got BT's FTTP900 offering fitted some months ago.

I noticed that the supplied Smart Hub 2 seems to throttle our speeds by up to 80% of the speed being delivered through the OpenReach Modem.

Its been like that from day one - we've tried non-BT routers which deliver the full 900+ but we have the digital voice option on our line and there's not an easy work around.Plus BT do a lot of maintenance stuff in the background on the SH2 so .... I'd rather keep the SH2 in place.

Here goes with a wee summary:

If I connect my MacBook Pro directly (CAT 6 or CAT 😎 via PPoE to the OpenReach Modem then I constantly get speeds in excess of 900Mbps (917/170) with a lowest level Down/Up speeds of 880Mbps/120. I normally use for my speed checks as the BT Speedchecker doesn't seem to like MacOS and "hangs" on the test phase.

If disconnect all our Wifi devices (devices are all new with Wifi802.11AC) and simpIy directly connect the MacBook Pro (Gb port) to one of the ethernet ports on the SH2 only get 150 - 250Mbps (compared to the OpenReach modems demonstrated values of 900Mbps+. As you can see from my screenshot the SH2 status page says Downstream 1000Mbps and Upstream 1000Mbps with Full Fibre mode set to ON.

It seems we have a very stable FTTP connection and kudos to OpenReach / BT  team here for delivering a great service.

MODS, I wonder if you could give your thoughts here? Do you think the SH2 is faulty or just has a wrong "profile" installed? Enclose screenshot of our SH2 broadband status page (with IP address blanked out). I've swapped out the SH2 > OpenReach fibre modem ethernet cables several times with tested CAT 6 / 8 but it makes no difference to the speed from the SH2. As I said a PPoE connection direct to the OpenReach modem gives an amazing and very stable speed, just not through the SH2!

Best wishes and thanks in anticipation.


Screenshot 2021-12-21 at 14.49.49.png

0 Ratings
Message 2 of 10

Re: BT FTTP 900

The BT Smart Hub  2 is a router and modem combined. 

Unless I am misunderstanding your set-up, you can ditch the modem and use ONLY the SH2!!

0 Ratings
Message 3 of 10

Re: BT FTTP 900

I rather suspect the OP is referring to the ONT (optical modem)

Message 4 of 10

Re: BT FTTP 900

Hi Carlusha,

Thank you for your prompt reply - much appreciated.

The Fibre cable itself comes to our house via an outside wall and terminates on the Huawei 1-port fibre modem (I think OpenReach refer to it as an ONS) Optical Port inside the building There is a single ethernet cable which then runs from the ONS's own ethernet port into the SH2. Similar to the graphic here.

If I connect a PPoE device via ethernet to Port one on the Fibre ONS then I get 900Mbps+ Every time.

Our pathway from the Openreach "box" is

FTTP cable > ONS optical then CAT6 Port One > SH2 Gbps WAN port (Port 4).

If I connect the same PC/MacOS device (after deleting its PPoE configuration) to any of the Gbps port on the SH2I get 150 - 200Mbps. I've tried numerous factory resets and left the SH2 untouched for weeks on end but still land up with the fractional speed. Reattach the PC/Mac directly to the ONS port-one and bingo! 900Mbps. 

Port 4 on the SH2 is used in our FTTP setup as directed in BT's FTTP setup instructions.

Carlusha, I'm pretty sure the ONS is not a router - the OpenReach engineer delivered a SH2 for us to use as it has Wifi etc and from what I understand that seems to be the standard FTTP900 install.

Am I doing something wrong or would a new SH2 / router help?

Best wishes



0 Ratings
Message 5 of 10

Re: BT FTTP 900

Have you tried a factory reset of the BT hub, make sure you turn off Smart Setup afterwards.

Edit: Just noticed you have already tried that.

The hub will always show connected at 1000Mbps as it is just a GbE link to the ONT.

0 Ratings
Message 6 of 10

Re: BT FTTP 900

Hi Liquorice . Thanks for your reply. I'm trying to understand why if I connect a device directly to the ONT Ethernet Port I get 900Mbps plus and yet the SH2 only gives me a fraction of that, even when connected by CAT 6 to its own Gbps port? 

Is it possible that Openreach  / BT set my SH2 up with a speed profile that was less than 900Mbps?Would the MODS be able to shed any light on this? I've searched the forums and there does appear to be an occasional issue with SH2's throttling the speed on a FTTP connection but I don't see any indication of the state of their fibre connection before the problems began.

We have a pretty punchy fibre connection to the exchange, a two minute walk away so even our old copper / FTTC connections were excellent. 


0 Ratings
Message 7 of 10

Re: BT FTTP 900

The SH2 does throttle the speed initially on the upload, but i don't think it does on the download.

It might be worth calling customer services 0800 800150 to see if they will send a replacement hub. Post back if you get no joy from them.

Message 8 of 10

Re: BT FTTP 900


I rather suspect the OP is referring to the ONT (optical modem)

Oooops! My mistake. Thanks @licquorice and apologies @patchbench 

Message 9 of 10

Re: BT FTTP 900

Hi liquorice

Thanks for the info and I'll give them a call and post back. Merry Christmas!


0 Ratings
Message 10 of 10

Re: BT FTTP 900

Smart set up on the hub is switched off?

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings icon. If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted solution’
0 Ratings