cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
4,020 Views
Message 1 of 8

Could not establish secure connection to server

For weeks now I’ve been trying to access some websites, but for some odd reason the bt internet is not allowing me to. Keeps saying could not establish secure connection to server. This has never happened before with my other providers, seems to be an issue with BT. I’ve tried resetting thebhub, also turned off smart hub settings but still the same problem. Pls help
0 Ratings
7 REPLIES 7
4,015 Views
Message 2 of 8

Re: Could not establish secure connection to server

Are you using the Safari web browser on an Apple computer?

 

0 Ratings
4,008 Views
Message 3 of 8

Re: Could not establish secure connection to server

Safari browser
0 Ratings
4,004 Views
Message 4 of 8

Re: Could not establish secure connection to server

0 Ratings
3,983 Views
Message 5 of 8

Re: Could not establish secure connection to server

But I don’t understand, all ththe se sites were working a few weeks ago when I was with Plusnet, but as soon as I got bt, this has started to happen to some sites!!
0 Ratings
3,972 Views
Message 6 of 8

Re: Could not establish secure connection to server

Have you actually done a factory reset of the home hub?

Factory reset your home hub

0 Ratings
3,950 Views
Message 7 of 8

Re: Could not establish secure connection to server

No I’ve not done this
0 Ratings
3,934 Views
Message 8 of 8

Re: Could not establish secure connection to server

Then try it to see if it helps.

0 Ratings