cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
970 Views
Message 1 of 2

BT Smart Hub 2 keeps disconnecting my Raspberry Pi

Good morning,

I am having several issue in trying to setup a Raspberry Pi+OpenVPN with my BT Smart Hub 2. 

A similar setup did work for a friend using Sky router, so I presume it must be something in the BT router settings that stops my Raspberry Pi to work. I tried several settings navigating in my SH2 Manager page, but none of them resulted to work. 

Ultimately when I start the Raspberry I can see the route table as I expected but as soon as I access to the Raspberry (like doing a simple "scp", or trying to access to internet) it stops working and can see from the Technical Log that the device is disconnected. It reconnects after a couple of seconds but the ip table misses the relevant one of my VPN.

This is the sequence of messages as seen in the Technical Log referred to Raspberry IP address when trying to scp from Raspberry:

ARP [del] br0 

LAN [DEL] ARP

Wire Lan Port 2 Down, Speed 10 Mbps

A device disconnected from Ethernet port 2

DHCP Device disconnected

Wire Lan Port 2 Up, Speed 100 Mbps 

A device connected from Ethernet port 2

Receive a DHCP request

Lan [ADD] ARP

DHCP Device connected

Lan IPv6 Neighbour Discovery events: NEIGHBOR_SOLICIT

ARP [add] br0 (eth1)

 

At this stage the relevant IP of my VPN disappears from the route table. 

Should I be aware of something in SH2 that prevents the use of a VPN via Raspberry? I am a residential customer. 

Any help would be much appreciated, thank you in advance. 

Cheers,

A

 

0 Ratings
1 REPLY 1
945 Views
Message 2 of 2

Re: BT Smart Hub 2 keeps disconnecting my Raspberry Pi

I run a Raspberry Pi 4 VPN server and it is solid with the Smarthub 2.

I use a wired connection with a static IP address and run Pivpn/Wireguard.

0 Ratings