Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 8

Ethernet speed not right - FTTP

Go to solution

I recently upgraded to 900 FTTP with Smart Hub 2.

My wifi speeds are fine at 400 but my ethernet speeds are wrong and I can't work out why.

At first I thought it was maybe old devices but on testing it on my laptop which has 10/100/1000 port it still failed to get beyond 100...

I have a Mac book pro which is lightening fast and have ordered a USB C - ethernet adaptor which arrives tomorrow.  I will plug it into router and see what speed I get from it, if it doesn't work right then I will know its the ethernet in router that's causing it as that will be 4th device on 4 different cat 6 cables. 



0 Ratings
Message 2 of 8

Re: Ethernet speed not right - FTTP

Go to solution

Are you using a 10/100 port expander (unmanaged switch)

Message 3 of 8

Re: Ethernet speed not right - FTTP

Go to solution

You can easily rule out the router by setting up a direct PPPoE wired connection between PC/Laptop and the ONT.

Message 4 of 8

Re: Ethernet speed not right - FTTP

Go to solution

Thank you.  I am not using any switches.

I wasn't sure how to set up PPPoE connection but found some instructions.

One of them reads

"Enter the information you received from your ISP, such as account name, password and the PPPoE service name, if your service provider requires it"

What/where is this info sorry.

Thank you very much for helping.

0 Ratings
Message 5 of 8

Re: Ethernet speed not right - FTTP

Go to solution

User name:

Password: bt

Message 6 of 8

Re: Ethernet speed not right - FTTP

Go to solution


Thank you for helping me.

I managed to do this , this morning on my dell laptop E5510 Latitude which has a 1g port.  

Tests never once went over 300 when connected from unit on wall directly to laptop on  when I used the speedtest website it wasn't over 100 so erratic . 

When I run a BT speed test when logged in for them to check line - it says I am getting full 900 but im sadly not.

I thought it might be something to do with the cable im using Cat 6a cable so I reverted to a cat 6 cable to see if he cable was faulty - but same results. 

Note when I run wifi it is around 400 I am receiving which is good (next to router). 

I will try it on my newer MacBook Pro when the adaptor arrives to eliminate a faulty ethernet port on Dell but I feel I may be clutching at straws with that !

0 Ratings
Message 7 of 8

Re: Ethernet speed not right - FTTP

Go to solution

You've effectivly prooved it is an issue with the Dell. If the ONT is only supplying 300mb you wouldn't get 400mb via wireless through the hub.

It is worth a try running TCPOtimiser to see if it can fix it. It's free  and will correct the network card settings.

When you open it move the slider all the way to the right, tick Modify all adapters and select optimal at the bottom and apply.

Message 8 of 8

Re: Ethernet speed not right - FTTP

Go to solution

Hi Thank you very much for your help.

My USBC-ethernet adaptor for my MacBook so I tried that and he presto ...  900!   so it must be the dell laptop!

I tried the app you kindly provided and it actually boosted ethernet on it to around 300 but that will do as I mainly use the MacBook anyway.

So at least I now know I am indeed getting the 900.

My TV must be capped at 100 as on reading up the Samsung even 2020 versions where being shipped with 100 not 1g ports.

My media box which is wired also - that's a different story - one minute its showing 73 day later 300 then back down again so not sure why that is happening but I know its not the cable as I plugged my MacBook into it and it went straight up to 860. 

My S20FE and Oculus Quest 2 Headset are wifi 6 capable.  I was thinking of getting AX86U router to boost them but worried the range / speed might not be as good as I am getting as am right now ( I can receive 500 on s20fe on wifi) what's your thoughts on this - I do like the idea of splitting the 2.4 and 5.   With wifi 6.... I take it if I have say a media box on wired and I want to connect to it on wifi 6 device that wouldn't be an issue would it (right now it works fine connecting via DLNA)